awstats.pl in AWStats 6.2 allows remote attackers to execute arbitrary commands via shell…
Priority LOW 25Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- No fix listed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA.
Summary
awstats.pl in AWStats 6.2 allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) "pluginmode", (2) "loadplugin", or (3) "noloadplugin" parameters.
Why it matters now
EPSS 0.01793 78th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:awstats:awstats:4.0:*:*:*:*:*:*:* | 4.0 | Vulnerable | Awstats |
| cpe:2.3:a:awstats:awstats:5.0:*:*:*:*:*:*:* | 5.0 | Vulnerable | Awstats |
| cpe:2.3:a:awstats:awstats:5.1:*:*:*:*:*:*:* | 5.1 | Vulnerable | Awstats |
| cpe:2.3:a:awstats:awstats:5.2:*:*:*:*:*:*:* | 5.2 | Vulnerable | Awstats |
| cpe:2.3:a:awstats:awstats:5.3:*:*:*:*:*:*:* | 5.3 | Vulnerable | Awstats |
| cpe:2.3:a:awstats:awstats:5.4:*:*:*:*:*:*:* | 5.4 | Vulnerable | Awstats |
| cpe:2.3:a:awstats:awstats:5.5:*:*:*:*:*:*:* | 5.5 | Vulnerable | Awstats |
| cpe:2.3:a:awstats:awstats:5.7:*:*:*:*:*:*:* | 5.7 | Vulnerable | Awstats |
| cpe:2.3:a:awstats:awstats:5.8:*:*:*:*:*:*:* | 5.8 | Vulnerable | Awstats |
| cpe:2.3:a:awstats:awstats:5.9:*:*:*:*:*:*:* | 5.9 | Vulnerable | Awstats |
- cpe:2.3:a:awstats:awstats:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Awstats
- cpe:2.3:a:awstats:awstats:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Awstats
- cpe:2.3:a:awstats:awstats:5.1:*:*:*:*:*:*:* Versions 5.1 Vulnerable ·Awstats
- cpe:2.3:a:awstats:awstats:5.2:*:*:*:*:*:*:* Versions 5.2 Vulnerable ·Awstats
- cpe:2.3:a:awstats:awstats:5.3:*:*:*:*:*:*:* Versions 5.3 Vulnerable ·Awstats
- cpe:2.3:a:awstats:awstats:5.4:*:*:*:*:*:*:* Versions 5.4 Vulnerable ·Awstats
- cpe:2.3:a:awstats:awstats:5.5:*:*:*:*:*:*:* Versions 5.5 Vulnerable ·Awstats
- cpe:2.3:a:awstats:awstats:5.7:*:*:*:*:*:*:* Versions 5.7 Vulnerable ·Awstats
- cpe:2.3:a:awstats:awstats:5.8:*:*:*:*:*:*:* Versions 5.8 Vulnerable ·Awstats
- cpe:2.3:a:awstats:awstats:5.9:*:*:*:*:*:*:* Versions 5.9 Vulnerable ·Awstats
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:awstats:awstats:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Awstats |
| cpe:2.3:a:awstats:awstats:6.1:*:*:*:*:*:*:* | 6.1 | Vulnerable | Awstats |
| cpe:2.3:a:awstats:awstats:6.2:*:*:*:*:*:*:* | 6.2 | Vulnerable | Awstats |
| cpe:2.3:a:awstats:awstats:6.3:*:*:*:*:*:*:* | 6.3 | Vulnerable | Awstats |
- cpe:2.3:a:awstats:awstats:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Awstats
- cpe:2.3:a:awstats:awstats:6.1:*:*:*:*:*:*:* Versions 6.1 Vulnerable ·Awstats
- cpe:2.3:a:awstats:awstats:6.2:*:*:*:*:*:*:* Versions 6.2 Vulnerable ·Awstats
- cpe:2.3:a:awstats:awstats:6.3:*:*:*:*:*:*:* Versions 6.3 Vulnerable ·Awstats
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2005-0362
- 2026-10-03 Alias added: GHSA-gxfj-hj3g-hcm2
References
Other 1
More Awstats vulnerabilities
- TI-2005-00101 AWStats 6.1, and other versions before 6.3, allows remote attackers to execute arbitrary… CVSS 2.0HIGH 7.5
- TI-2006-02178 The web interface for AWStats 6.4 and 6.5, when statistics updates are enabled, allows… CVSS 2.0MEDIUM 5.1
- TI-2010-04100 awstats.cgi in AWStats before 7.0 accepts a configdir parameter in the URL, which allows… CVSS 2.0HIGH 7.5
- TI-2020-17782 In AWStats through 7.7, cgi-bin/awstats.pl?config= accepts an absolute pathname, even… CVSS 3.1CRITICAL 9.8
- TI-2017-14709 Awstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of… CVSS 3.0CRITICAL 9.8
- TI-2005-00394 Direct code injection vulnerability in awstats.pl in AWStats 6.3 and 6.4 allows remote… CVSS 2.0HIGH 7.5
Sources
- CVE-2005-0362 · CVE Program
- CVE-2005-0362 · NVD
- FIRST EPSS
- GHSA-gxfj-hj3g-hcm2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences