The editing form in RWiki 2.1.0pre1 through 2.1.0 allows remote attackers to execute…
Priority LOW 36Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
The editing form in RWiki 2.1.0pre1 through 2.1.0 allows remote attackers to execute arbitrary Ruby code via unknown attack vectors.
Why it matters now
EPSS 0.01555 75th percentileScored 2026-11-07
Fix Fixed rwiki (RubyGems): 2.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | rwiki (RubyGems) | 2.1.0pre1 to before 2.1.1 | 2.1.1 | Patch available | GHSA-wwmf-6p58-6vj2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- rwiki (RubyGems) Vendor— Affected 2.1.0pre1 to before 2.1.1 Fixed in 2.1.1 Patch available GHSA-wwmf-6p58-6vj2
Remediation
- Fix · GHSA-wwmf-6p58-6vj2 rwiki (RubyGems) Fixed in 2.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2006-2582
- 2026-10-03 Alias added: GHSA-wwmf-6p58-6vj2
References
Advisory 2
More Rwiki vulnerabilities
- TI-2006-02512 Cross-site scripting (XSS) vulnerability in Wiki content in RWiki 2.1.0pre1 through 2.1.0… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2006-2582 · CVE Program
- CVE-2006-2582 · NVD
- FIRST EPSS
- GHSA-wwmf-6p58-6vj2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences