Directory traversal vulnerability in index.php in phpSysInfo 2.5.1 allows remote…
Priority LOW 31CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Directory traversal vulnerability in index.php in phpSysInfo 2.5.1 allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence and a trailing null (%00) byte in the lng parameter, which will display a different error message if the file exists.
Why it matters now
EPSS 0.05574 92nd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed phpsysinfo/phpsysinfo (Packagist): 3.2.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpsysinfo/phpsysinfo (Packagist) | before 3.2.5 | 3.2.5 | Patch available | GHSA-2wxv-3g4v-p76p |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpsysinfo/phpsysinfo (Packagist) Vendor— Affected before 3.2.5 Fixed in 3.2.5 Patch available GHSA-2wxv-3g4v-p76p
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpsysinfo:phpsysinfo:*:*:*:*:*:*:*:* | up to 2.5.1 | Vulnerable | phpsysinfo |
- cpe:2.3:a:phpsysinfo:phpsysinfo:*:*:*:*:*:*:*:* Versions up to 2.5.1 Vulnerable ·phpsysinfo
Remediation
- Fix · GHSA-2wxv-3g4v-p76p phpsysinfo/phpsysinfo (Packagist) Fixed in 3.2.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2006-3360
- 2026-10-03 Alias added: GHSA-2wxv-3g4v-p76p
References
Exploit 2
Advisory 4
More Phpsysinfo vulnerabilities
- TI-2005-00812 phpSysInfo 2.3 allows remote attackers to obtain sensitive information via a direct… CVSS 2.0MEDIUM 5.0
- TI-2023-26715 Cross Site Request Forgery (CSRF) vulnerability in Phpsysinfo version 3.4.3 allows a… CVSS 3.1MEDIUM 6.5
- TI-2005-00813 Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when… CVSS 2.0MEDIUM 4.3
- TI-2005-03173 HTTP response splitting vulnerability in index.php in phpSysInfo 2.4 and earlier, as used… CVSS 2.0MEDIUM 4.3
- TI-2007-03917 Cross-site scripting (XSS) vulnerability in index.php in phpSysInfo 2.5.4-dev and earlier… CVSS 2.0MEDIUM 4.3
- TI-2003-00504 Directory traversal vulnerability in phpSysInfo 2.1 and earlier allows attackers with… CVSS 2.0LOW 3.6
Sources
- CVE-2006-3360 · CVE Program
- CVE-2006-3360 · NVD
- FIRST EPSS
- GHSA-2wxv-3g4v-p76p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences