Zope 2.7.0 to 2.7.8, 2.8.0 to 2.8.7, and 2.9.0 to 2.9.3 (Zope2) does not disable the…
Priority LOW 12Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
Zope 2.7.0 to 2.7.8, 2.8.0 to 2.8.7, and 2.9.0 to 2.9.3 (Zope2) does not disable the "raw" command when providing untrusted users with restructured text (reStructuredText) functionality from docutils, which allows local users to read arbitrary files.
Why it matters now
EPSS 0.00422 36th percentileScored 2026-11-07
Fix Fixed Zope2 (PyPI): 2.7.8, 2.8.7, 2.9.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Zope2 (PyPI) | 2.7.0 to before 2.7.8 | 2.7.8 | Patch available | GHSA-jcjp-qqpq-pc54 |
| — | Zope2 (PyPI) | 2.8.0 to before 2.8.7 | 2.8.7 | Patch available | GHSA-jcjp-qqpq-pc54 |
| — | Zope2 (PyPI) | 2.9.0 to before 2.9.3 | 2.9.3 | Patch available | GHSA-jcjp-qqpq-pc54 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Zope2 (PyPI) Vendor— Affected 2.7.0 to before 2.7.8 Fixed in 2.7.8 Patch available GHSA-jcjp-qqpq-pc54
- Zope2 (PyPI) Vendor— Affected 2.8.0 to before 2.8.7 Fixed in 2.8.7 Patch available GHSA-jcjp-qqpq-pc54
- Zope2 (PyPI) Vendor— Affected 2.9.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-jcjp-qqpq-pc54
CPE configurations NVD · 21
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zope:zope:2.7.0:*:*:*:*:*:*:* | 2.7.0 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.7.1:*:*:*:*:*:*:* | 2.7.1 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.7.2:*:*:*:*:*:*:* | 2.7.2 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.7.3:*:*:*:*:*:*:* | 2.7.3 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.7.4:*:*:*:*:*:*:* | 2.7.4 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.7.5:*:*:*:*:*:*:* | 2.7.5 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.7.6:*:*:*:*:*:*:* | 2.7.6 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.7.7:*:*:*:*:*:*:* | 2.7.7 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.7.8:*:*:*:*:*:*:* | 2.7.8 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | zopefoundation |
- cpe:2.3:a:zope:zope:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.7.2:*:*:*:*:*:*:* Versions 2.7.2 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.7.3:*:*:*:*:*:*:* Versions 2.7.3 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.7.4:*:*:*:*:*:*:* Versions 2.7.4 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.7.5:*:*:*:*:*:*:* Versions 2.7.5 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.7.6:*:*:*:*:*:*:* Versions 2.7.6 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.7.7:*:*:*:*:*:*:* Versions 2.7.7 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.7.8:*:*:*:*:*:*:* Versions 2.7.8 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·zopefoundation
Show 11 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zope:zope:2.8.1:*:*:*:*:*:*:* | 2.8.1 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.8.2:*:*:*:*:*:*:* | 2.8.2 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.8.3:*:*:*:*:*:*:* | 2.8.3 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.8.4:*:*:*:*:*:*:* | 2.8.4 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.8.5:*:*:*:*:*:*:* | 2.8.5 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.8.6:*:*:*:*:*:*:* | 2.8.6 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.8.7:*:*:*:*:*:*:* | 2.8.7 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.9.0:*:*:*:*:*:*:* | 2.9.0 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.9.1:*:*:*:*:*:*:* | 2.9.1 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.9.2:*:*:*:*:*:*:* | 2.9.2 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.9.3:*:*:*:*:*:*:* | 2.9.3 | Vulnerable | zopefoundation |
- cpe:2.3:a:zope:zope:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.8.2:*:*:*:*:*:*:* Versions 2.8.2 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.8.3:*:*:*:*:*:*:* Versions 2.8.3 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.8.4:*:*:*:*:*:*:* Versions 2.8.4 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.8.5:*:*:*:*:*:*:* Versions 2.8.5 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.8.6:*:*:*:*:*:*:* Versions 2.8.6 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.8.7:*:*:*:*:*:*:* Versions 2.8.7 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.9.0:*:*:*:*:*:*:* Versions 2.9.0 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.9.1:*:*:*:*:*:*:* Versions 2.9.1 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.9.2:*:*:*:*:*:*:* Versions 2.9.2 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.9.3:*:*:*:*:*:*:* Versions 2.9.3 Vulnerable ·zopefoundation
Remediation
- Fix · GHSA-jcjp-qqpq-pc54 Zope2 (PyPI) Fixed in 2.7.8 Advisory →
- Fix · GHSA-jcjp-qqpq-pc54 Zope2 (PyPI) Fixed in 2.8.7 Advisory →
- Fix · GHSA-jcjp-qqpq-pc54 Zope2 (PyPI) Fixed in 2.9.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2006-3458
- 2026-10-03 Alias added: GHSA-jcjp-qqpq-pc54
References
Advisory 5
More zopefoundation Zope vulnerabilities
- TI-2011-03162 Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through… CVSS 2.0HIGH 9.3
- TI-2000-00062 The DTML implementation in the Z Object Publishing Environment (Zope) allows remote… CVSS 2.0HIGH 10.0
- TI-2021-12302 Remote Code Execution via traversal in TAL expressions CVSS 3.1HIGH 8.8
- TI-2021-12342 Remote Code Execution via traversal in TAL expressions CVSS 3.1HIGH 8.8
- TI-2005-03148 docutils in Zope 2.6, 2.7 before 2.7.8, and 2.8 before 2.8.2 allows remote attackers to… CVSS 2.0HIGH 7.5
- TI-2000-00483 The DocumentTemplate package in Zope 2.2 and earlier allows a remote attacker to modify… CVSS 2.0HIGH 7.5
Sources
- CVE-2006-3458 · CVE Program
- CVE-2006-3458 · NVD
- FIRST EPSS
- GHSA-jcjp-qqpq-pc54 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences