The LazyUser class in the AuthenticationMiddleware for Django 0.95 does not properly…
Priority LOW 31Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
The LazyUser class in the AuthenticationMiddleware for Django 0.95 does not properly cache the user name across requests, which allows remote authenticated users to gain the privileges of a different user.
Why it matters now
EPSS 0.01308 70th percentileScored 2026-11-07
Fix Fixed Django (PyPI): 1.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 0.95 to before 1.0 | 1.0 | Patch available | GHSA-mwv2-398h-v489 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 0.95 to before 1.0 Fixed in 1.0 Patch available GHSA-mwv2-398h-v489
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:django_project:django:0.95:*:*:*:*:*:*:* | 0.95 | Vulnerable | Django Project |
- cpe:2.3:a:django_project:django:0.95:*:*:*:*:*:*:* Versions 0.95 Vulnerable ·Django Project
Remediation
- Fix · GHSA-mwv2-398h-v489 Django (PyPI) Fixed in 1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2007-0405
- 2026-10-03 Alias added: GHSA-mwv2-398h-v489
References
More Django Project Django vulnerabilities
- TI-2007-00394 bin/compile-messages.py in Django 0.95 does not quote argument strings before invoking… CVSS 2.0HIGH 7.5
- TI-2007-05594 Cross-site request forgery (CSRF) vulnerability in the admin panel in Django 0.96 allows… CVSS 2.0MEDIUM 6.8
- TI-2009-02541 The Admin media handler in core/servers/basehttp.py in Django 1.0 and 0.96 does not… CVSS 2.0MEDIUM 5.0
- TI-2008-02208 Cross-site scripting (XSS) vulnerability in the login form in the administration… CVSS 2.0MEDIUM 4.3
- TI-2007-05485 The internationalization (i18n) framework in Django 0.91, 0.95, 0.95.1, and 0.96, and as… CVSS 2.0LOW 2.6
Sources
- CVE-2007-0405 · CVE Program
- CVE-2007-0405 · NVD
- FIRST EPSS
- GHSA-mwv2-398h-v489 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences