Cross-site scripting (XSS) vulnerability in the login form in the administration…
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the login form in the administration application in Django 0.91 before 0.91.2, 0.95 before 0.95.3, and 0.96 before 0.96.2 allows remote attackers to inject arbitrary web script or HTML via the URI of a certain previous request.
Why it matters now
EPSS 0.01312 70th percentileScored 2026-11-07
Fix Fixed Django (PyPI): 0.91.2, 0.95.3, 0.96.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 0.91 to before 0.91.2 | 0.91.2 | Patch available | GHSA-54qj-48vx-cr9f |
| — | Django (PyPI) | 0.95 to before 0.95.3 | 0.95.3 | Patch available | GHSA-54qj-48vx-cr9f |
| — | Django (PyPI) | 0.96 to before 0.96.2 | 0.96.2 | Patch available | GHSA-54qj-48vx-cr9f |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 0.91 to before 0.91.2 Fixed in 0.91.2 Patch available GHSA-54qj-48vx-cr9f
- Django (PyPI) Vendor— Affected 0.95 to before 0.95.3 Fixed in 0.95.3 Patch available GHSA-54qj-48vx-cr9f
- Django (PyPI) Vendor— Affected 0.96 to before 0.96.2 Fixed in 0.96.2 Patch available GHSA-54qj-48vx-cr9f
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:django_project:django:0.91:*:*:*:*:*:*:* | 0.91 | Vulnerable | Django Project |
| cpe:2.3:a:django_project:django:0.95:*:*:*:*:*:*:* | 0.95 | Vulnerable | Django Project |
| cpe:2.3:a:django_project:django:0.96:*:*:*:*:*:*:* | 0.96 | Vulnerable | Django Project |
- cpe:2.3:a:django_project:django:0.91:*:*:*:*:*:*:* Versions 0.91 Vulnerable ·Django Project
- cpe:2.3:a:django_project:django:0.95:*:*:*:*:*:*:* Versions 0.95 Vulnerable ·Django Project
- cpe:2.3:a:django_project:django:0.96:*:*:*:*:*:*:* Versions 0.96 Vulnerable ·Django Project
Remediation
- Fix · GHSA-54qj-48vx-cr9f Django (PyPI) Fixed in 0.91.2 Advisory →
- Fix · GHSA-54qj-48vx-cr9f Django (PyPI) Fixed in 0.95.3 Advisory →
- Fix · GHSA-54qj-48vx-cr9f Django (PyPI) Fixed in 0.96.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2008-2302
- 2026-10-03 Alias added: GHSA-54qj-48vx-cr9f
References
Other 11
- ADV-2008-1618
- https://github.com/django/django/commit/50ce7fb57d79e8940ccf6e2781f2f01df029b5c5
- https://github.com/django/django/commit/6e657e2c404a96e744748209e896d8a69c15fdf2
- https://github.com/django/django/commit/7791e5c050cebf86d868c5dab7092185b125fdc9
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2008-1.yaml
- https://web.archive.org/web/20080725022008/http://secunia.com/advisories/30291
- https://web.archive.org/web/20081012011038/http://secunia.com/advisories/30250
- https://web.archive.org/web/20170222015451/http://securitytracker.com/id?1020028
- https://web.archive.org/web/20200228153339/http://www.securityfocus.com/bid/29209
- http://www.djangoproject.com/weblog/2008/may/14/security
More Django Project Django vulnerabilities
- TI-2007-00394 bin/compile-messages.py in Django 0.95 does not quote argument strings before invoking… CVSS 2.0HIGH 7.5
- TI-2007-05594 Cross-site request forgery (CSRF) vulnerability in the admin panel in Django 0.96 allows… CVSS 2.0MEDIUM 6.8
- TI-2007-00395 The LazyUser class in the AuthenticationMiddleware for Django 0.95 does not properly… CVSS 2.0MEDIUM 6.5
- TI-2009-02541 The Admin media handler in core/servers/basehttp.py in Django 1.0 and 0.96 does not… CVSS 2.0MEDIUM 5.0
- TI-2007-05485 The internationalization (i18n) framework in Django 0.91, 0.95, 0.95.1, and 0.96, and as… CVSS 2.0LOW 2.6
Sources
- CVE-2008-2302 · CVE Program
- CVE-2008-2302 · NVD
- FIRST EPSS
- GHSA-54qj-48vx-cr9f · GitHub Advisory Database · CC BY 4.0
- CVE-2008-2302 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences