Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin before 1.5.7 allow remote…
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin before 1.5.7 allow remote attackers to inject arbitrary web script or HTML via (1) the page info, or the page name in a (2) AttachFile, (3) RenamePage, or (4) LocalSiteMap action.
Why it matters now
EPSS 0.02484 84th percentileScored 2026-11-07
Fix Fixed moin (PyPI): 1.5.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moin (PyPI) | before 1.5.7 | 1.5.7 | Patch available | GHSA-m84w-vgwf-p893 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moin (PyPI) Vendor— Affected before 1.5.7 Fixed in 1.5.7 Patch available GHSA-m84w-vgwf-p893
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moinmoin:moinmoin:*:*:*:*:*:*:*:* | up to 1.5.6 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.0:*:*:*:*:*:*:* | 1.5.0 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.1:*:*:*:*:*:*:* | 1.5.1 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.2:*:*:*:*:*:*:* | 1.5.2 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.3:*:*:*:*:*:*:* | 1.5.3 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.3_rc1:*:*:*:*:*:*:* | 1.5.3_rc1 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.3_rc2:*:*:*:*:*:*:* | 1.5.3_rc2 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.4:*:*:*:*:*:*:* | 1.5.4 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.5:*:*:*:*:*:*:* | 1.5.5 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.5_rc1:*:*:*:*:*:*:* | 1.5.5_rc1 | Vulnerable | Moinmoin |
- cpe:2.3:a:moinmoin:moinmoin:*:*:*:*:*:*:*:* Versions up to 1.5.6 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.0:*:*:*:*:*:*:* Versions 1.5.0 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.1:*:*:*:*:*:*:* Versions 1.5.1 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.2:*:*:*:*:*:*:* Versions 1.5.2 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.3:*:*:*:*:*:*:* Versions 1.5.3 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.3_rc1:*:*:*:*:*:*:* Versions 1.5.3_rc1 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.3_rc2:*:*:*:*:*:*:* Versions 1.5.3_rc2 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.4:*:*:*:*:*:*:* Versions 1.5.4 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.5:*:*:*:*:*:*:* Versions 1.5.5 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.5_rc1:*:*:*:*:*:*:* Versions 1.5.5_rc1 Vulnerable ·Moinmoin
Remediation
- Fix · GHSA-m84w-vgwf-p893 moin (PyPI) Fixed in 1.5.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2007-0857
- 2026-10-03 Alias added: GHSA-m84w-vgwf-p893
References
More Moinmoin vulnerabilities
- TI-2004-01340 Unknown vulnerability in the PageEditor in MoinMoin 1.2.2 and earlier, related to Access… CVSS 2.0HIGH 10.0
- TI-2008-00748 Directory traversal vulnerability in MoinMoin 1.5.8 and earlier allows remote attackers… CVSS 2.0MEDIUM 5.0
- TI-2004-01339 Unknown vulnerability in MoinMoin 1.2.2 and earlier allows remote attackers to gain… CVSS 2.0HIGH 7.5
- TI-2004-00649 MoinMoin 1.2.1 and earlier allows remote attackers to gain privileges by creating a user… CVSS 2.0HIGH 7.5
- TI-2008-01860 The user form processing (userform.py) in MoinMoin before 1.6.3, when using ACLs or a… CVSS 2.0MEDIUM 6.8
- TI-2007-02340 Cross-site scripting (XSS) vulnerability in index.php in MoinMoin 1.5.7 allows remote… CVSS 2.0MEDIUM 5.8
Sources
- CVE-2007-0857 · CVE Program
- CVE-2007-0857 · NVD
- FIRST EPSS
- GHSA-m84w-vgwf-p893 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences