MoinMoin before 20070507 does not properly enforce ACLs for calendars and includes, which…
Priority LOW 26Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
MoinMoin before 20070507 does not properly enforce ACLs for calendars and includes, which allows remote attackers to read certain pages via unspecified vectors.
Why it matters now
EPSS 0.01486 74th percentileScored 2026-11-07
Fix Fixed moin (PyPI): 1.5.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moin (PyPI) | before 1.5.8 | 1.5.8 | Patch available | GHSA-cmg7-xr2j-4r9v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moin (PyPI) Vendor— Affected before 1.5.8 Fixed in 1.5.8 Patch available GHSA-cmg7-xr2j-4r9v
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:ubuntu:ubuntu_linux:6.06_lts:*:*:*:*:*:*:* | 6.06_lts | Running on | Ubuntu |
| cpe:2.3:o:ubuntu:ubuntu_linux:6.10:*:*:*:*:*:*:* | 6.10 | Running on | Ubuntu |
| cpe:2.3:o:ubuntu:ubuntu_linux:7.04:*:*:*:*:*:*:* | 7.04 | Running on | Ubuntu |
| cpe:2.3:a:moinmoin:moinmoin:*:*:*:*:*:*:*:* | up to 1.5.7 | Vulnerable | Moinmoin |
- cpe:2.3:o:ubuntu:ubuntu_linux:6.06_lts:*:*:*:*:*:*:* Versions 6.06_lts Running on ·Ubuntu
- cpe:2.3:o:ubuntu:ubuntu_linux:6.10:*:*:*:*:*:*:* Versions 6.10 Running on ·Ubuntu
- cpe:2.3:o:ubuntu:ubuntu_linux:7.04:*:*:*:*:*:*:* Versions 7.04 Running on ·Ubuntu
- cpe:2.3:a:moinmoin:moinmoin:*:*:*:*:*:*:*:* Versions up to 1.5.7 Vulnerable ·Moinmoin
Remediation
- Fix · GHSA-cmg7-xr2j-4r9v moin (PyPI) Fixed in 1.5.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2007-2637
- 2026-10-03 Alias added: GHSA-cmg7-xr2j-4r9v
References
More Moinmoin vulnerabilities
- TI-2004-01340 Unknown vulnerability in the PageEditor in MoinMoin 1.2.2 and earlier, related to Access… CVSS 2.0HIGH 10.0
- TI-2008-00748 Directory traversal vulnerability in MoinMoin 1.5.8 and earlier allows remote attackers… CVSS 2.0MEDIUM 5.0
- TI-2004-01339 Unknown vulnerability in MoinMoin 1.2.2 and earlier allows remote attackers to gain… CVSS 2.0HIGH 7.5
- TI-2004-00649 MoinMoin 1.2.1 and earlier allows remote attackers to gain privileges by creating a user… CVSS 2.0HIGH 7.5
- TI-2008-01860 The user form processing (userform.py) in MoinMoin before 1.6.3, when using ACLs or a… CVSS 2.0MEDIUM 6.8
- TI-2007-02340 Cross-site scripting (XSS) vulnerability in index.php in MoinMoin 1.5.7 allows remote… CVSS 2.0MEDIUM 5.8
Sources
- CVE-2007-2637 · CVE Program
- CVE-2007-2637 · NVD
- FIRST EPSS
- GHSA-cmg7-xr2j-4r9v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences