PHPMailer 1.7, when configured to use sendmail, allows remote attackers to execute…
Priority LOW 35Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
PHPMailer 1.7, when configured to use sendmail, allows remote attackers to execute arbitrary shell commands via shell metacharacters in the SendmailSend function in class.phpmailer.php.
Why it matters now
EPSS 0.02407 84th percentileScored 2026-11-07
Fix Fixed phpmailer/phpmailer (Packagist): 1.7.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpmailer/phpmailer (Packagist) | before 1.7.4 | 1.7.4 | Patch available | GHSA-6h78-85v2-mmch |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpmailer/phpmailer (Packagist) Vendor— Affected before 1.7.4 Fixed in 1.7.4 Patch available GHSA-6h78-85v2-mmch
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmailer:phpmailer:1.7:*:*:*:*:*:*:* | 1.7 | Vulnerable | PHPMailer |
| cpe:2.3:a:phpmailer:phpmailer:1.7.1:*:*:*:*:*:*:* | 1.7.1 | Vulnerable | PHPMailer |
| cpe:2.3:a:phpmailer:phpmailer:1.7.2:*:*:*:*:*:*:* | 1.7.2 | Vulnerable | PHPMailer |
| cpe:2.3:a:phpmailer:phpmailer:1.7.3:*:*:*:*:*:*:* | 1.7.3 | Vulnerable | PHPMailer |
| cpe:2.3:a:phpmailer:phpmailer:1.73:*:*:*:*:*:*:* | 1.73 | Vulnerable | PHPMailer |
- cpe:2.3:a:phpmailer:phpmailer:1.7:*:*:*:*:*:*:* Versions 1.7 Vulnerable ·PHPMailer
- cpe:2.3:a:phpmailer:phpmailer:1.7.1:*:*:*:*:*:*:* Versions 1.7.1 Vulnerable ·PHPMailer
- cpe:2.3:a:phpmailer:phpmailer:1.7.2:*:*:*:*:*:*:* Versions 1.7.2 Vulnerable ·PHPMailer
- cpe:2.3:a:phpmailer:phpmailer:1.7.3:*:*:*:*:*:*:* Versions 1.7.3 Vulnerable ·PHPMailer
- cpe:2.3:a:phpmailer:phpmailer:1.73:*:*:*:*:*:*:* Versions 1.73 Vulnerable ·PHPMailer
Remediation
- Fix · GHSA-6h78-85v2-mmch phpmailer/phpmailer (Packagist) Fixed in 1.7.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2007-3215
- 2026-10-03 Alias added: GHSA-6h78-85v2-mmch
References
Other 15
- http://sourceforge.net/project/shownotes.php?release_id=517428&group_id=157374
- 76139
- https://sourceforge.net/tracker/index.php?func=detail&aid=1734811&group_id=26031&atid=385707
- 37206
- ADV-2007-2267
- http://larholm.com/2007/06/11/phpmailer-0day-remote-execution/
- http://yehg.net/lab/pr0js/advisories/%5BvTiger_5.2.1%5D_rce
- ADV-2007-2161
- 20111005 vTiger CRM 5.2.x <= Remote Code Execution Vulnerability
- https://github.com/PHPMailer/PHPMailer/security/advisories/GHSA-6h78-85v2-mmch
- https://github.com/PHPMailer/PHPMailer
- https://seclists.org/fulldisclosure/2011/Oct/223
- https://sourceforge.net/p/phpmailer/bugs/192
- https://web.archive.org/web/20070714054359/http://larholm.com/2007/06/11/phpmailer-0day-remote-execution
- https://yehg.net/lab/pr0js/advisories/%5BvTiger_5.2.1%5D_rce
More Phpmailer vulnerabilities
- TI-2005-01714 The Data function in class.smtp.php in PHPMailer 1.7.2 and earlier allows remote… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2007-3215 · CVE Program
- CVE-2007-3215 · NVD
- FIRST EPSS
- GHSA-6h78-85v2-mmch · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences