Rails before 1.2.4, as used for Ruby on Rails, allows remote attackers and ActiveResource…
Priority LOW 30CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Rails before 1.2.4, as used for Ruby on Rails, allows remote attackers and ActiveResource servers to determine the existence of arbitrary files and read arbitrary XML files via the Hash.from_xml (Hash#from_xml) method, which uses XmlSimple (XML::Simple) unsafely, as demonstrated by reading passwords from the Pidgin (Gaim) .purple/accounts.xml file.
Why it matters now
EPSS 0.03969 90th percentileScored 2026-11-07
Fix Fixed rails (RubyGems): 1.2.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | rails (RubyGems) | before 1.2.4 | 1.2.4 | Patch available | GHSA-fjfg-q662-gm6j |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- rails (RubyGems) Vendor— Affected before 1.2.4 Fixed in 1.2.4 Patch available GHSA-fjfg-q662-gm6j
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:david_hansson:ruby_on_rails:*:*:*:*:*:*:*:* | up to 1.2.3 | Vulnerable | David Hansson |
- cpe:2.3:a:david_hansson:ruby_on_rails:*:*:*:*:*:*:*:* Versions up to 1.2.3 Vulnerable ·David Hansson
Remediation
- Fix · GHSA-fjfg-q662-gm6j rails (RubyGems) Fixed in 1.2.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2007-5379
- 2026-10-03 Alias added: GHSA-fjfg-q662-gm6j
References
Other 11
- ADV-2007-4238
- ADV-2007-3508
- 40717
- http://bugs.gentoo.org/show_bug.cgi?id=195315
- http://weblog.rubyonrails.org/2007/10/5/rails-1-2-4-maintenance-release
- http://docs.info.apple.com/article.html?artnum=307179
- http://dev.rubyonrails.org/ticket/8453
- https://github.com/rails/rails
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rails/CVE-2007-5379.yml
- https://rubyonrails.org/2007/10/5/rails-1-2-4-maintenance-release
- https://web.archive.org/web/20090602000500/http://dev.rubyonrails.org/ticket/8453
More David Hansson Ruby On Rails vulnerabilities
- TI-2007-05167 Session fixation vulnerability in Rails before 1.2.4, as used for Ruby on Rails, allows… CVSS 2.0MEDIUM 6.8
Sources
- CVE-2007-5379 · CVE Program
- CVE-2007-5379 · NVD
- FIRST EPSS
- GHSA-fjfg-q662-gm6j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences