Session fixation vulnerability in Rails before 1.2.4, as used for Ruby on Rails, allows…
Priority LOW 36CWE-384Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-384.
Summary
Session fixation vulnerability in Rails before 1.2.4, as used for Ruby on Rails, allows remote attackers to hijack web sessions via unspecified vectors related to "URL-based sessions."
Why it matters now
EPSS 0.03576 89th percentileScored 2026-11-07
Fix Fixed rails (RubyGems): 1.2.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | rails (RubyGems) | before 1.2.4 | 1.2.4 | Patch available | GHSA-jwhv-rgqc-fqj5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- rails (RubyGems) Vendor— Affected before 1.2.4 Fixed in 1.2.4 Patch available GHSA-jwhv-rgqc-fqj5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:david_hansson:ruby_on_rails:*:*:*:*:*:*:*:* | up to 1.2.3 | Vulnerable | David Hansson |
- cpe:2.3:a:david_hansson:ruby_on_rails:*:*:*:*:*:*:*:* Versions up to 1.2.3 Vulnerable ·David Hansson
Remediation
- Fix · GHSA-jwhv-rgqc-fqj5 rails (RubyGems) Fixed in 1.2.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2007-5380
- 2026-10-03 Alias added: GHSA-jwhv-rgqc-fqj5
References
Advisory 6
Other 7
- ADV-2007-4238
- ADV-2007-3508
- http://bugs.gentoo.org/show_bug.cgi?id=195315
- http://weblog.rubyonrails.org/2007/10/5/rails-1-2-4-maintenance-release
- http://docs.info.apple.com/article.html?artnum=307179
- https://github.com/rails/rails
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rails/CVE-2007-5380.yml
More David Hansson Ruby On Rails vulnerabilities
- TI-2007-05166 Rails before 1.2.4, as used for Ruby on Rails, allows remote attackers and ActiveResource… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2007-5380 · CVE Program
- CVE-2007-5380 · NVD
- FIRST EPSS
- GHSA-jwhv-rgqc-fqj5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences