Cross-site scripting (XSS) vulnerability in MoinMoin 1.5.x through 1.5.8 and 1.6.x before…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in MoinMoin 1.5.x through 1.5.8 and 1.6.x before 1.6.1 allows remote attackers to inject arbitrary web script or HTML via the login action.
Why it matters now
EPSS 0.0175 77th percentileScored 2026-11-07
Fix Fixed moin (PyPI): 1.6.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moin (PyPI) | 1.5 – 1.5.8 | — | No fix listed | GHSA-53wj-6m7w-j6mj |
| — | moin (PyPI) | 1.6 to before 1.6.1 | 1.6.1 | Patch available | GHSA-53wj-6m7w-j6mj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moin (PyPI) Vendor— Affected 1.5 – 1.5.8 Fixed in — No fix listed GHSA-53wj-6m7w-j6mj
- moin (PyPI) Vendor— Affected 1.6 to before 1.6.1 Fixed in 1.6.1 Patch available GHSA-53wj-6m7w-j6mj
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moinmoin:moinmoin:1.5.0:*:*:*:*:*:*:* | 1.5.0 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.1:*:*:*:*:*:*:* | 1.5.1 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.2:*:*:*:*:*:*:* | 1.5.2 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.3:*:*:*:*:*:*:* | 1.5.3 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.3_rc1:*:*:*:*:*:*:* | 1.5.3_rc1 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.3_rc2:*:*:*:*:*:*:* | 1.5.3_rc2 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.4:*:*:*:*:*:*:* | 1.5.4 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.5:*:*:*:*:*:*:* | 1.5.5 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.5_rc1:*:*:*:*:*:*:* | 1.5.5_rc1 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.5a:*:*:*:*:*:*:* | 1.5.5a | Vulnerable | Moinmoin |
- cpe:2.3:a:moinmoin:moinmoin:1.5.0:*:*:*:*:*:*:* Versions 1.5.0 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.1:*:*:*:*:*:*:* Versions 1.5.1 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.2:*:*:*:*:*:*:* Versions 1.5.2 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.3:*:*:*:*:*:*:* Versions 1.5.3 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.3_rc1:*:*:*:*:*:*:* Versions 1.5.3_rc1 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.3_rc2:*:*:*:*:*:*:* Versions 1.5.3_rc2 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.4:*:*:*:*:*:*:* Versions 1.5.4 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.5:*:*:*:*:*:*:* Versions 1.5.5 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.5_rc1:*:*:*:*:*:*:* Versions 1.5.5_rc1 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.5a:*:*:*:*:*:*:* Versions 1.5.5a Vulnerable ·Moinmoin
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moinmoin:moinmoin:1.5.6:*:*:*:*:*:*:* | 1.5.6 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.7:*:*:*:*:*:*:* | 1.5.7 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.5.8:*:*:*:*:*:*:* | 1.5.8 | Vulnerable | Moinmoin |
| cpe:2.3:a:moinmoin:moinmoin:1.6.0:*:*:*:*:*:*:* | 1.6.0 | Vulnerable | Moinmoin |
- cpe:2.3:a:moinmoin:moinmoin:1.5.6:*:*:*:*:*:*:* Versions 1.5.6 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.7:*:*:*:*:*:*:* Versions 1.5.7 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.5.8:*:*:*:*:*:*:* Versions 1.5.8 Vulnerable ·Moinmoin
- cpe:2.3:a:moinmoin:moinmoin:1.6.0:*:*:*:*:*:*:* Versions 1.6.0 Vulnerable ·Moinmoin
Remediation
- Fix · GHSA-53wj-6m7w-j6mj moin (PyPI) Fixed in 1.6.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2008-0780
- 2026-10-03 Alias added: GHSA-53wj-6m7w-j6mj
References
Advisory 6
More Moinmoin vulnerabilities
- TI-2004-01340 Unknown vulnerability in the PageEditor in MoinMoin 1.2.2 and earlier, related to Access… CVSS 2.0HIGH 10.0
- TI-2008-00748 Directory traversal vulnerability in MoinMoin 1.5.8 and earlier allows remote attackers… CVSS 2.0MEDIUM 5.0
- TI-2004-01339 Unknown vulnerability in MoinMoin 1.2.2 and earlier allows remote attackers to gain… CVSS 2.0HIGH 7.5
- TI-2004-00649 MoinMoin 1.2.1 and earlier allows remote attackers to gain privileges by creating a user… CVSS 2.0HIGH 7.5
- TI-2008-01860 The user form processing (userform.py) in MoinMoin before 1.6.3, when using ACLs or a… CVSS 2.0MEDIUM 6.8
- TI-2007-02340 Cross-site scripting (XSS) vulnerability in index.php in MoinMoin 1.5.7 allows remote… CVSS 2.0MEDIUM 5.8
Sources
- CVE-2008-0780 · CVE Program
- CVE-2008-0780 · NVD
- FIRST EPSS
- GHSA-53wj-6m7w-j6mj · GitHub Advisory Database · CC BY 4.0
- CVE-2008-0780 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences