Cross-site scripting (XSS) vulnerability in Apache Struts before 1.2.9-162.31.1 on SUSE…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in Apache Struts before 1.2.9-162.31.1 on SUSE Linux Enterprise (SLE) 11, before 1.2.9-108.2 on SUSE openSUSE 10.3, before 1.2.9-198.2 on SUSE openSUSE 11.0, and before 1.2.9-162.163.2 on SUSE openSUSE 11.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to "insufficient quoting of parameters."
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | struts:struts (Maven) | before 1.2.9-162.31.1 | 1.2.9-162.31.1 | Patch available | GHSA-wcgx-2hvx-5cwr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- struts:struts (Maven) Vendor— Affected before 1.2.9-162.31.1 Fixed in 1.2.9-162.31.1 Patch available GHSA-wcgx-2hvx-5cwr
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:struts:1.0.2:*:*:*:*:*:*:* | 1.0.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:1.1:*:*:*:*:*:*:* | 1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:1.2.4:*:*:*:*:*:*:* | 1.2.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:1.2.7:*:*:*:*:*:*:* | 1.2.7 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:1.2.8:*:*:*:*:*:*:* | 1.2.8 | Vulnerable | Apache |
| cpe:2.3:o:novell:suse_linux:11:-:enterprise:*:*:*:*:* | 11 | Running on | Novell |
| cpe:2.3:o:opensuse:opensuse:10.3:*:*:*:*:*:*:* | 10.3 | Running on | openSUSE |
| cpe:2.3:o:opensuse:opensuse:11.0:*:*:*:*:*:*:* | 11.0 | Running on | openSUSE |
| cpe:2.3:o:opensuse:opensuse:11.1:*:*:*:*:*:*:* | 11.1 | Running on | openSUSE |
- cpe:2.3:a:apache:struts:1.0.2:*:*:*:*:*:*:* Versions 1.0.2 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:1.1:*:*:*:*:*:*:* Versions 1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:1.2.4:*:*:*:*:*:*:* Versions 1.2.4 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:1.2.7:*:*:*:*:*:*:* Versions 1.2.7 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:1.2.8:*:*:*:*:*:*:* Versions 1.2.8 Vulnerable ·Apache
- cpe:2.3:o:novell:suse_linux:11:-:enterprise:*:*:*:*:* Versions 11 Running on ·Novell
- cpe:2.3:o:opensuse:opensuse:10.3:*:*:*:*:*:*:* Versions 10.3 Running on ·openSUSE
- cpe:2.3:o:opensuse:opensuse:11.0:*:*:*:*:*:*:* Versions 11.0 Running on ·openSUSE
- cpe:2.3:o:opensuse:opensuse:11.1:*:*:*:*:*:*:* Versions 11.1 Running on ·openSUSE
Remediation
- Fix · GHSA-wcgx-2hvx-5cwr struts:struts (Maven) Fixed in 1.2.9-162.31.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2008-2025
- 2026-10-03 Alias added: GHSA-wcgx-2hvx-5cwr
References
Other 7
- http://support.novell.com/security/cve/CVE-2008-2025.html
- 53380
- https://launchpad.net/bugs/cve/2008-2025
- https://bugzilla.novell.com/show_bug.cgi?id=385273
- https://github.com/apache/struts
- https://web.archive.org/web/20090410082732/http://secunia.com/advisories/34642
- https://web.archive.org/web/20090411051126/http://secunia.com/advisories/34567
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2008-2025 · CVE Program
- CVE-2008-2025 · NVD
- FIRST EPSS
- GHSA-wcgx-2hvx-5cwr · GitHub Advisory Database · CC BY 4.0
- CVE-2008-2025 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences