Read the docs
TI-2008-04111 Aliases CVE-2008-4310GHSA-wfrc-r6c6-7j9r

httputils.rb in WEBrick in Ruby 1.8.1 and 1.8.5, as used in Red Hat Enterprise Linux 4…

Priority MEDIUM 49CWE-399Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Complete
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-399 and the CVSS impact.

Summary

httputils.rb in WEBrick in Ruby 1.8.1 and 1.8.5, as used in Red Hat Enterprise Linux 4 and 5, allows remote attackers to cause a denial of service (CPU consumption) via a crafted HTTP request. NOTE: this issue exists because of an incomplete fix for CVE-2008-3656.

Why it matters now

EPSS 0.13553 96th percentileScored 2026-11-07
Fix Fixed webrick (RubyGems): 1.3.1Red Hat: 1 advisory

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—webrick (RubyGems)before 1.3.11.3.1Patch availableGHSA-wfrc-r6c6-7j9r
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • webrick (RubyGems) Vendor— Affected before 1.3.1 Fixed in 1.3.1 Patch available GHSA-wfrc-r6c6-7j9r

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:ruby-lang:ruby:1.8.1:*:*:*:*:*:*:*1.8.1Vulnerableruby
cpe:2.3:a:ruby-lang:ruby:1.8.5:*:*:*:*:*:*:*1.8.5Vulnerableruby
  • cpe:2.3:a:ruby-lang:ruby:1.8.1:*:*:*:*:*:*:* Versions 1.8.1 Vulnerable ·ruby
  • cpe:2.3:a:ruby-lang:ruby:1.8.5:*:*:*:*:*:*:* Versions 1.8.5 Vulnerable ·ruby

Remediation

  • Fix · GHSA-wfrc-r6c6-7j9r webrick (RubyGems) Fixed in 1.3.1 Advisory →

Red Hat 1 advisory

  • RHSA-2008:0981 Released 2008-12-04 · Red Hat rating Moderate
    ruby security update
    • Red Hat Enterprise Linux (v. 5 server) ruby-1.8.5-5.el5_2.6, ruby-1.8.5-5.el5_2.6.i386, ruby-1.8.5-5.el5_2.6.ia64 +33
    • Red Hat Enterprise Linux AS version 4 irb-1.8.1-7.el4_7.2, irb-1.8.1-7.el4_7.2.i386, irb-1.8.1-7.el4_7.2.ia64 +25
    • Red Hat Enterprise Linux Desktop (v. 5 client) ruby-1.8.5-5.el5_2.6, ruby-1.8.5-5.el5_2.6.i386, ruby-docs-1.8.5-5.el5_2.6 +11
    • Red Hat Enterprise Linux Desktop Workstation (v. 5 client) ruby-1.8.5-5.el5_2.6, ruby-devel-1.8.5-5.el5_2.6, ruby-devel-1.8.5-5.el5_2.6.i386 +2
    • Red Hat Enterprise Linux Desktop version 4 irb-1.8.1-7.el4_7.2, irb-1.8.1-7.el4_7.2.i386, ruby-1.8.1-7.el4_7.2 +11
    • Red Hat Enterprise Linux ES version 4 irb-1.8.1-7.el4_7.2, irb-1.8.1-7.el4_7.2.i386, irb-1.8.1-7.el4_7.2.ia64 +18
    • Red Hat Enterprise Linux WS version 4 irb-1.8.1-7.el4_7.2, irb-1.8.1-7.el4_7.2.i386, irb-1.8.1-7.el4_7.2.ia64 +18

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux (v. 5 server)Fixed RHSA-2008:0981
Red Hat Enterprise Linux AS version 4Fixed RHSA-2008:0981
Red Hat Enterprise Linux Desktop (v. 5 client)Fixed RHSA-2008:0981
Red Hat Enterprise Linux Desktop Workstation (v. 5 client)Fixed RHSA-2008:0981
Red Hat Enterprise Linux Desktop version 4Fixed RHSA-2008:0981
Red Hat Enterprise Linux ES version 4Fixed RHSA-2008:0981
Red Hat Enterprise Linux WS version 4Fixed RHSA-2008:0981

Timeline

  1. 2026-10-02 Threatist record created from CVE-2008-4310
  2. 2026-10-03 Alias added: GHSA-wfrc-r6c6-7j9r

References

  • TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
  • TI-2017-12709 Ruby before 2.4.3 allows Net::FTP command injection. CVSS 3.0HIGH 8.8
  • TI-2008-03501 Algorithmic complexity vulnerability in the WEBrick::HTTPUtils.split_header_value… CVSS 2.0HIGH 7.8
  • TI-2021-09891 In Ruby through 3.0 on Windows, a remote attacker can submit a crafted path when a Web… CVSS 3.1HIGH 7.5
  • TI-2013-03637 Heap-based buffer overflow in Ruby 1.8, 1.9 before 1.9.3-p484, 2.0 before 2.0.0-p353, 2.1… CVSS 2.0MEDIUM 6.8
  • TI-2018-11751 An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5… CVSS 3.0CRITICAL 9.8
See all 92 →

Sources