Multiple untrusted search path vulnerabilities in Portage before 2.1.4.5 include the…
Priority LOW 30Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- —
- Confidentiality · integrity · availability
- Complete · Complete · Complete
- Fix status
- No fix listed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA.
Summary
Multiple untrusted search path vulnerabilities in Portage before 2.1.4.5 include the current working directory in the Python search path, which allows local users to execute arbitrary code via a modified Python module that is loaded by the (1) ys-apps/portage, (2) net-mail/fetchmail, (3) app-editors/leo ebuilds, and other ebuilds.
Why it matters now
EPSS 0.00338 27th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gentoo:portage:*:*:*:*:*:*:*:* | up to 2.1.4.4 | Vulnerable | gentoo |
| cpe:2.3:a:gentoo:portage:2.0.51.22:r3:*:*:*:*:*:* | 2.0.51.22 r3 | Vulnerable | gentoo |
| cpe:2.3:a:gentoo:portage:2.1.1:r2:*:*:*:*:*:* | 2.1.1 r2 | Vulnerable | gentoo |
| cpe:2.3:a:gentoo:portage:2.1.3.10:*:*:*:*:*:*:* | 2.1.3.10 | Vulnerable | gentoo |
| cpe:2.3:a:gentoo:portage:2.1.3.11:*:*:*:*:*:*:* | 2.1.3.11 | Vulnerable | gentoo |
- cpe:2.3:a:gentoo:portage:*:*:*:*:*:*:*:* Versions up to 2.1.4.4 Vulnerable ·gentoo
- cpe:2.3:a:gentoo:portage:2.0.51.22:r3:*:*:*:*:*:* Versions 2.0.51.22 r3 Vulnerable ·gentoo
- cpe:2.3:a:gentoo:portage:2.1.1:r2:*:*:*:*:*:* Versions 2.1.1 r2 Vulnerable ·gentoo
- cpe:2.3:a:gentoo:portage:2.1.3.10:*:*:*:*:*:*:* Versions 2.1.3.10 Vulnerable ·gentoo
- cpe:2.3:a:gentoo:portage:2.1.3.11:*:*:*:*:*:*:* Versions 2.1.3.11 Vulnerable ·gentoo
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2008-4394
- 2026-10-03 Alias added: GHSA-wg82-w6jx-9hqg
References
Advisory 1
More gentoo Portage vulnerabilities
- TI-2016-09197 In Gentoo Portage before 3.0.47, there is missing PGP validation of executed code: the… CVSS 3.1CRITICAL 9.8
- TI-2013-01869 The urlopen function in pym/portage/util/_urlopen.py in Gentoo Portage 2.1.12, when using… CVSS 2.0HIGH 9.3
- TI-2004-02643 Ebuild in Gentoo may change directory and file permissions depending on the order of… CVSS 3.0HIGH 7.1
- TI-2004-01775 Portage before 2.0.50-r3 allows local users to overwrite arbitrary files via a hard link attack on the lockfiles. CVSS 3.1MEDIUM 5.5
- TI-2019-14618 Gentoo Portage through 2.3.84 allows local users to place a Trojan horse plugin in the… CVSS 3.1MEDIUM 5.5
- TI-2007-05962 etc-update in Portage before 2.1.3.11 on Gentoo Linux relies on the umask to set… CVSS 2.0LOW 2.1
Sources
- CVE-2008-4394 · CVE Program
- CVE-2008-4394 · NVD
- FIRST EPSS
- GHSA-wg82-w6jx-9hqg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences