Gentoo Portage through 2.3.84 allows local users to place a Trojan horse plugin in the…
Priority LOW 24CWE-362Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Gentoo Portage through 2.3.84 allows local users to place a Trojan horse plugin in the /usr/lib64/nagios/plugins directory by leveraging access to the nagios user account, because this directory is writable in between a call to emake and a call to fowners.
Why it matters now
EPSS 0.0027 19th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2019-20384
- 2026-10-03 Alias added: GHSA-fj76-6r22-qfgv
References
More gentoo Portage vulnerabilities
- TI-2016-09197 In Gentoo Portage before 3.0.47, there is missing PGP validation of executed code: the… CVSS 3.1CRITICAL 9.8
- TI-2013-01869 The urlopen function in pym/portage/util/_urlopen.py in Gentoo Portage 2.1.12, when using… CVSS 2.0HIGH 9.3
- TI-2004-02643 Ebuild in Gentoo may change directory and file permissions depending on the order of… CVSS 3.0HIGH 7.1
- TI-2008-04191 Multiple untrusted search path vulnerabilities in Portage before 2.1.4.5 include the… CVSS 2.0MEDIUM 6.9
- TI-2004-01775 Portage before 2.0.50-r3 allows local users to overwrite arbitrary files via a hard link attack on the lockfiles. CVSS 3.1MEDIUM 5.5
- TI-2007-05962 etc-update in Portage before 2.1.3.11 on Gentoo Linux relies on the umask to set… CVSS 2.0LOW 2.1
Sources
- CVE-2019-20384 · CVE Program
- CVE-2019-20384 · NVD
- FIRST EPSS
- GHSA-fj76-6r22-qfgv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences