Multiple directory traversal vulnerabilities in Apache Struts 2.0.x before 2.0.12 and…
Priority MEDIUM 61CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Multiple directory traversal vulnerabilities in Apache Struts 2.0.x before 2.0.12 and 2.1.x before 2.1.3 allow remote attackers to read arbitrary files via a ..%252f (encoded dot dot slash) in a URI with a /struts/ path, related to (1) FilterDispatcher in 2.0.x and (2) DefaultStaticContentLoader in 2.1.x.
Why it matters now
EPSS 0.72711 99th percentileScored 2026-11-07
Fix Fixed org.apache.struts:struts2-core (Maven): 2.0.12, 2.1.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.struts:struts2-core (Maven) | 2.0.0 to before 2.0.12 | 2.0.12 | Patch available | GHSA-wv7g-xhvw-8hcp |
| — | org.apache.struts:struts2-core (Maven) | 2.1.0 to before 2.1.3 | 2.1.3 | Patch available | GHSA-wv7g-xhvw-8hcp |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.0.0 to before 2.0.12 Fixed in 2.0.12 Patch available GHSA-wv7g-xhvw-8hcp
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.1.0 to before 2.1.3 Fixed in 2.1.3 Patch available GHSA-wv7g-xhvw-8hcp
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:struts:2.0.6:*:*:*:*:*:*:* | 2.0.6 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.8:*:*:*:*:*:*:* | 2.0.8 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.9:*:*:*:*:*:*:* | 2.0.9 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.11:*:*:*:*:*:*:* | 2.0.11 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.11.1:*:*:*:*:*:*:* | 2.0.11.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.11.2:*:*:*:*:*:*:* | 2.0.11.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.1.2_beta:*:*:*:*:*:*:* | 2.1.2_beta | Vulnerable | Apache |
- cpe:2.3:a:apache:struts:2.0.6:*:*:*:*:*:*:* Versions 2.0.6 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.8:*:*:*:*:*:*:* Versions 2.0.8 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.9:*:*:*:*:*:*:* Versions 2.0.9 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.11:*:*:*:*:*:*:* Versions 2.0.11 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.11.1:*:*:*:*:*:*:* Versions 2.0.11.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.11.2:*:*:*:*:*:*:* Versions 2.0.11.2 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.1.2_beta:*:*:*:*:*:*:* Versions 2.1.2_beta Vulnerable ·Apache
Remediation
- Fix · GHSA-wv7g-xhvw-8hcp org.apache.struts:struts2-core (Maven) Fixed in 2.0.12 Advisory →
- Fix · GHSA-wv7g-xhvw-8hcp org.apache.struts:struts2-core (Maven) Fixed in 2.1.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2008-6505
- 2026-10-03 Alias added: GHSA-wv7g-xhvw-8hcp
References
Advisory 3
Other 8
- http://issues.apache.org/struts/browse/WW-2779
- 49733
- 49734
- https://github.com/apache/struts/commit/04fcefa44bae1263c7cad6986a9dafed67f0164f
- https://github.com/apache/struts/commit/1f1c996eb1f0f3e2193fba0075f62ccd04e3c0c3
- https://github.com/apache/struts
- https://web.archive.org/web/20081208214512/http://secunia.com/advisories/32497
- https://web.archive.org/web/20111025094319/http://www.securityfocus.com/bid/32104
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2008-6505 · CVE Program
- CVE-2008-6505 · NVD
- FIRST EPSS
- GHSA-wv7g-xhvw-8hcp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences