Read the docs
TI-2008-06230 Aliases CVE-2008-6540GHSA-grw3-hjjm-5cjm

DotNetNuke before 4.8.2, during installation or upgrade, does not warn the administrator…

Priority LOW 28CWE-264Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
Partial · Partial · Partial
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.

Summary

DotNetNuke before 4.8.2, during installation or upgrade, does not warn the administrator when the default (1) ValidationKey and (2) DecryptionKey values cannot be modified in the web.config file, which allows remote attackers to bypass intended access restrictions by using the default keys.

Why it matters now

EPSS 0.02475 84th percentileScored 2026-11-07
Fix Fixed DotNetNuke.Core (NuGet): 4.8.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—DotNetNuke.Core (NuGet)before 4.8.24.8.2Patch availableGHSA-grw3-hjjm-5cjm
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • DotNetNuke.Core (NuGet) Vendor— Affected before 4.8.2 Fixed in 4.8.2 Patch available GHSA-grw3-hjjm-5cjm

CPE configurations NVD · 17

CPEVersionsRoleVendor
cpe:2.3:a:dnnsoftware:dotnetnuke:*:*:*:*:*:*:*:*up to 4.8.1VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:1.0.6:*:*:*:*:*:*:*1.0.6VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:1.0.7:*:*:*:*:*:*:*1.0.7VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:1.0.8:*:*:*:*:*:*:*1.0.8VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:1.0.9:*:*:*:*:*:*:*1.0.9VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:1.0.10d:*:*:*:*:*:*:*1.0.10dVulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:1.0.10e:*:*:*:*:*:*:*1.0.10eVulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:2.1.1:*:*:*:*:*:*:*2.1.1VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:2.1.2:*:*:*:*:*:*:*2.1.2VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:3.0.7:*:*:*:*:*:*:*3.0.7VulnerableDotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:*:*:*:*:*:*:*:* Versions up to 4.8.1 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:1.0.6:*:*:*:*:*:*:* Versions 1.0.6 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:1.0.7:*:*:*:*:*:*:* Versions 1.0.7 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:1.0.8:*:*:*:*:*:*:* Versions 1.0.8 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:1.0.9:*:*:*:*:*:*:* Versions 1.0.9 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:1.0.10d:*:*:*:*:*:*:* Versions 1.0.10d Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:1.0.10e:*:*:*:*:*:*:* Versions 1.0.10e Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:3.0.7:*:*:*:*:*:*:* Versions 3.0.7 Vulnerable ·DotNetNuke (DNN)
Show 7 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:dnnsoftware:dotnetnuke:3.0.8:*:*:*:*:*:*:*3.0.8VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:3.0.11:*:*:*:*:*:*:*3.0.11VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:3.1.0:*:*:*:*:*:*:*3.1.0VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:3.3.5:*:*:*:*:*:*:*3.3.5VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.0:*:*:*:*:*:*:*4.0VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.3.5:*:*:*:*:*:*:*4.3.5VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.5.2:*:*:*:*:*:*:*4.5.2VulnerableDotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:3.0.8:*:*:*:*:*:*:* Versions 3.0.8 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:3.0.11:*:*:*:*:*:*:* Versions 3.0.11 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:3.1.0:*:*:*:*:*:*:* Versions 3.1.0 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:3.3.5:*:*:*:*:*:*:* Versions 3.3.5 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.3.5:*:*:*:*:*:*:* Versions 4.3.5 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.5.2:*:*:*:*:*:*:* Versions 4.5.2 Vulnerable ·DotNetNuke (DNN)

Remediation

  • Fix · GHSA-grw3-hjjm-5cjm DotNetNuke.Core (NuGet) Fixed in 4.8.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2008-6540
  2. 2026-10-03 Alias added: GHSA-grw3-hjjm-5cjm

References

  • TI-2017-07201 Code injection in DotNetNuke CMS Fixed in 9.1.1 KEVCVSS 3.1HIGH 8.8
  • TI-2018-12944 DNN (aka DotNetNuke) 9.2 through 9.2.2 uses a weak encryption algorithm to protect input… KEVCVSS 3.1HIGH 7.5
  • TI-2018-11271 DNN (aka DotNetNuke) 9.2 through 9.2.1 uses a weak encryption algorithm to protect input parameters. KEVCVSS 3.1HIGH 7.5
  • TI-2015-02468 The installation wizard in DotNetNuke (DNN) before 7.4.1 allows remote attackers to… CVSS 3.0CRITICAL 9.8
  • TI-2025-39546 DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite CVSS 3.1CRITICAL 10.0
  • TI-2018-12945 DNN (aka DotNetNuke) 9.2 through 9.2.2 incorrectly converts encryption key source values… CVSS 3.1HIGH 7.5
See all 75 →

Sources