Code injection in DotNetNuke CMS Fixed in 9.1.1
Priority CRITICAL 97Exploited in the wildCWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
DNN (aka DotNetNuke) before 9.1.1 has Remote Code Execution via a cookie, aka "2017-08 (Critical) Possible remote code execution on DNN sites."
Why it matters now
Exploitation Active In CISA KEV since 2021-11-03CISA due date 2022-05-03Known ransomware use
EPSS 0.94789 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed DotNetNuke.Core (NuGet): 9.1.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| DotNetNuke | DotNetNuke CMS Fixed in 9.1.1 | DotNetNuke CMS Fixed in 9.1.1 | — | No fix listed | CNA |
| — | DotNetNuke.Core (NuGet) | before 9.1.1 | 9.1.1 | Patch available | GHSA-x2rg-fmcv-crq5 |
- DotNetNuke CMS Fixed in 9.1.1 VendorDotNetNuke Affected DotNetNuke CMS Fixed in 9.1.1 Fixed in — No fix listed CNA
- DotNetNuke.Core (NuGet) Vendor— Affected before 9.1.1 Fixed in 9.1.1 Patch available GHSA-x2rg-fmcv-crq5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dnnsoftware:dotnetnuke:*:*:*:*:*:*:*:* | before 9.1.1 | Vulnerable | DotNetNuke (DNN) |
- cpe:2.3:a:dnnsoftware:dotnetnuke:*:*:*:*:*:*:*:* Versions before 9.1.1 Vulnerable ·DotNetNuke (DNN)
Remediation
- Fix · GHSA-x2rg-fmcv-crq5 DotNetNuke.Core (NuGet) Fixed in 9.1.1 Advisory →
Timeline
- 2021-11-03 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2017-9822
- 2026-10-03 Alias added: GHSA-x2rg-fmcv-crq5
References
More DotNetNuke vulnerabilities
- TI-2007-00644 Cross-site scripting (XSS) vulnerability in the IFrame module before 03.02.01 for… CVSS 2.0MEDIUM 6.8
- TI-2012-00950 Cross-site scripting (XSS) vulnerability in the telerik HTML editor in DotNetNuke before… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2017-9822 · CVE Program
- CVE-2017-9822 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-x2rg-fmcv-crq5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences