Multiple cross-site scripting (XSS) vulnerabilities in the web administration console in…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 allow remote attackers to inject arbitrary web script or HTML via the (1) name, (2) ip, (3) username, or (4) description parameter to console/portal/Server/Monitoring; or (5) the PATH_INFO to the default URI under console/portal/.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.geronimo.plugins:console (Maven) | 2.1.0 to before 2.1.4 | 2.1.4 | Patch available | GHSA-c372-x57p-6x7v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.geronimo.plugins:console (Maven) Vendor— Affected 2.1.0 to before 2.1.4 Fixed in 2.1.4 Patch available GHSA-c372-x57p-6x7v
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:geronimo:2.1:*:*:*:*:*:*:* | 2.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:geronimo:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:geronimo:2.1.2:*:*:*:*:*:*:* | 2.1.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:geronimo:2.1.3:*:*:*:*:*:*:* | 2.1.3 | Vulnerable | Apache |
- cpe:2.3:a:apache:geronimo:2.1:*:*:*:*:*:*:* Versions 2.1 Vulnerable ·Apache
- cpe:2.3:a:apache:geronimo:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:geronimo:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Apache
- cpe:2.3:a:apache:geronimo:2.1.3:*:*:*:*:*:*:* Versions 2.1.3 Vulnerable ·Apache
Remediation
- Fix · GHSA-c372-x57p-6x7v org.apache.geronimo.plugins:console (Maven) Fixed in 2.1.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2009-0038
- 2026-10-03 Alias added: GHSA-c372-x57p-6x7v
References
Patch 2
Other 6
- ADV-2009-1089
- https://github.com/apache/geronimo/commit/aa0c2c26dde8930cad924796af7c17a13d236b16
- https://github.com/apache/geronimo
- https://web.archive.org/web/20090419162753/http://secunia.com/advisories/34715
- https://web.archive.org/web/20090422192202/http://dsecrg.com/pages/vul/show.php?id=119
- https://web.archive.org/web/20200229223125/http://www.securityfocus.com/bid/34562
More Apache Geronimo vulnerabilities
- TI-2011-04311 Apache Geronimo 2.2.1 and earlier computes hash values for form parameters without… CVSS 2.0HIGH 7.8
- TI-2008-05234 Multiple directory traversal vulnerabilities in the web administration console in Apache… CVSS 2.0HIGH 9.4
- TI-2013-01564 The JMX Remoting functionality in Apache Geronimo 3.x before 3.0.1, as used in IBM… CVSS 2.0HIGH 10.0
- TI-2007-04403 The login method in LoginModule implementations in Apache Geronimo 2.0 does not throw… CVSS 2.0HIGH 10.0
- TI-2006-00245 Multiple cross-site scripting (XSS) vulnerabilities in Apache Geronimo 1.0 allow remote… CVSS 2.0MEDIUM 4.3
- TI-2009-00039 Multiple cross-site request forgery (CSRF) vulnerabilities in the web administration… CVSS 2.0MEDIUM 6.8
Sources
- CVE-2009-0038 · CVE Program
- CVE-2009-0038 · NVD
- FIRST EPSS
- GHSA-c372-x57p-6x7v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences