Read the docs
TI-2009-03898 Aliases CVE-2009-4109GHSA-vc99-gqjv-x726

The install wizard in DotNetNuke 4.0 through 5.1.4 does not prevent anonymous users from…

Priority LOW 25CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Partial · None · None
Fix status
No fix listed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA. Impact type from CWE-200.

Summary

The install wizard in DotNetNuke 4.0 through 5.1.4 does not prevent anonymous users from accessing functionality related to determination of the need for an upgrade, which allows remote attackers to access version information and possibly other sensitive information.

Why it matters now

EPSS 0.01218 68th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 24

CPEVersionsRoleVendor
cpe:2.3:a:dnnsoftware:dotnetnuke:4.0:*:*:*:*:*:*:*4.0VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.3.5:*:*:*:*:*:*:*4.3.5VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.4.1:*:*:*:*:*:*:*4.4.1VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.5.2:*:*:*:*:*:*:*4.5.2VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.5.4:*:*:*:*:*:*:*4.5.4VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.5.5:*:*:*:*:*:*:*4.5.5VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.6.0:*:*:*:*:*:*:*4.6.0VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.6.1:*:*:*:*:*:*:*4.6.1VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.6.2:*:*:*:*:*:*:*4.6.2VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.7.0:*:*:*:*:*:*:*4.7.0VulnerableDotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.3.5:*:*:*:*:*:*:* Versions 4.3.5 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.4.1:*:*:*:*:*:*:* Versions 4.4.1 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.5.2:*:*:*:*:*:*:* Versions 4.5.2 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.5.4:*:*:*:*:*:*:* Versions 4.5.4 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.5.5:*:*:*:*:*:*:* Versions 4.5.5 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.6.0:*:*:*:*:*:*:* Versions 4.6.0 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.6.1:*:*:*:*:*:*:* Versions 4.6.1 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.6.2:*:*:*:*:*:*:* Versions 4.6.2 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.7.0:*:*:*:*:*:*:* Versions 4.7.0 Vulnerable ·DotNetNuke (DNN)
Show 14 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.0:*:*:*:*:*:*:*4.8.0VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.1:*:*:*:*:*:*:*4.8.1VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.2:*:*:*:*:*:*:*4.8.2VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.3:*:*:*:*:*:*:*4.8.3VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.4:*:*:*:*:*:*:*4.8.4VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.9:*:*:*:*:*:*:*4.9VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.9.1:*:*:*:*:*:*:*4.9.1VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:4.9.2:*:*:*:*:*:*:*4.9.2VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:5.0:*:*:*:*:*:*:*5.0VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:5.1:*:*:*:*:*:*:*5.1VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.1:*:*:*:*:*:*:*5.1.1VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.2:*:*:*:*:*:*:*5.1.2VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.3:*:*:*:*:*:*:*5.1.3VulnerableDotNetNuke (DNN)
cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.4:*:*:*:*:*:*:*5.1.4VulnerableDotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.0:*:*:*:*:*:*:* Versions 4.8.0 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.1:*:*:*:*:*:*:* Versions 4.8.1 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.2:*:*:*:*:*:*:* Versions 4.8.2 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.3:*:*:*:*:*:*:* Versions 4.8.3 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.4:*:*:*:*:*:*:* Versions 4.8.4 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.9:*:*:*:*:*:*:* Versions 4.9 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.9.1:*:*:*:*:*:*:* Versions 4.9.1 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:4.9.2:*:*:*:*:*:*:* Versions 4.9.2 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:5.1:*:*:*:*:*:*:* Versions 5.1 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.1:*:*:*:*:*:*:* Versions 5.1.1 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.2:*:*:*:*:*:*:* Versions 5.1.2 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.3:*:*:*:*:*:*:* Versions 5.1.3 Vulnerable ·DotNetNuke (DNN)
  • cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.4:*:*:*:*:*:*:* Versions 5.1.4 Vulnerable ·DotNetNuke (DNN)

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2009-4109
  2. 2026-10-03 Alias added: GHSA-vc99-gqjv-x726

References

  • TI-2017-07201 Code injection in DotNetNuke CMS Fixed in 9.1.1 KEVCVSS 3.1HIGH 8.8
  • TI-2018-12944 DNN (aka DotNetNuke) 9.2 through 9.2.2 uses a weak encryption algorithm to protect input… KEVCVSS 3.1HIGH 7.5
  • TI-2018-11271 DNN (aka DotNetNuke) 9.2 through 9.2.1 uses a weak encryption algorithm to protect input parameters. KEVCVSS 3.1HIGH 7.5
  • TI-2015-02468 The installation wizard in DotNetNuke (DNN) before 7.4.1 allows remote attackers to… CVSS 3.0CRITICAL 9.8
  • TI-2025-39546 DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite CVSS 3.1CRITICAL 10.0
  • TI-2018-12945 DNN (aka DotNetNuke) 9.2 through 9.2.2 incorrectly converts encryption key source values… CVSS 3.1HIGH 7.5
See all 75 →

Sources