Cross-site scripting (XSS) vulnerability in the search functionality in DotNetNuke 4.8…
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- No fix listed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the search functionality in DotNetNuke 4.8 through 5.1.4 allows remote attackers to inject arbitrary web script or HTML via search terms that are not properly filtered before display in a custom results page.
Why it matters now
EPSS 0.01653 76th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.0:*:*:*:*:*:*:* | 4.8.0 | Vulnerable | DotNetNuke (DNN) |
| cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.1:*:*:*:*:*:*:* | 4.8.1 | Vulnerable | DotNetNuke (DNN) |
| cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.2:*:*:*:*:*:*:* | 4.8.2 | Vulnerable | DotNetNuke (DNN) |
| cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.3:*:*:*:*:*:*:* | 4.8.3 | Vulnerable | DotNetNuke (DNN) |
| cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.4:*:*:*:*:*:*:* | 4.8.4 | Vulnerable | DotNetNuke (DNN) |
| cpe:2.3:a:dnnsoftware:dotnetnuke:4.9:*:*:*:*:*:*:* | 4.9 | Vulnerable | DotNetNuke (DNN) |
| cpe:2.3:a:dnnsoftware:dotnetnuke:4.9.1:*:*:*:*:*:*:* | 4.9.1 | Vulnerable | DotNetNuke (DNN) |
| cpe:2.3:a:dnnsoftware:dotnetnuke:4.9.2:*:*:*:*:*:*:* | 4.9.2 | Vulnerable | DotNetNuke (DNN) |
| cpe:2.3:a:dnnsoftware:dotnetnuke:5.0:*:*:*:*:*:*:* | 5.0 | Vulnerable | DotNetNuke (DNN) |
| cpe:2.3:a:dnnsoftware:dotnetnuke:5.1:*:*:*:*:*:*:* | 5.1 | Vulnerable | DotNetNuke (DNN) |
- cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.0:*:*:*:*:*:*:* Versions 4.8.0 Vulnerable ·DotNetNuke (DNN)
- cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.1:*:*:*:*:*:*:* Versions 4.8.1 Vulnerable ·DotNetNuke (DNN)
- cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.2:*:*:*:*:*:*:* Versions 4.8.2 Vulnerable ·DotNetNuke (DNN)
- cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.3:*:*:*:*:*:*:* Versions 4.8.3 Vulnerable ·DotNetNuke (DNN)
- cpe:2.3:a:dnnsoftware:dotnetnuke:4.8.4:*:*:*:*:*:*:* Versions 4.8.4 Vulnerable ·DotNetNuke (DNN)
- cpe:2.3:a:dnnsoftware:dotnetnuke:4.9:*:*:*:*:*:*:* Versions 4.9 Vulnerable ·DotNetNuke (DNN)
- cpe:2.3:a:dnnsoftware:dotnetnuke:4.9.1:*:*:*:*:*:*:* Versions 4.9.1 Vulnerable ·DotNetNuke (DNN)
- cpe:2.3:a:dnnsoftware:dotnetnuke:4.9.2:*:*:*:*:*:*:* Versions 4.9.2 Vulnerable ·DotNetNuke (DNN)
- cpe:2.3:a:dnnsoftware:dotnetnuke:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·DotNetNuke (DNN)
- cpe:2.3:a:dnnsoftware:dotnetnuke:5.1:*:*:*:*:*:*:* Versions 5.1 Vulnerable ·DotNetNuke (DNN)
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.1:*:*:*:*:*:*:* | 5.1.1 | Vulnerable | DotNetNuke (DNN) |
| cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.2:*:*:*:*:*:*:* | 5.1.2 | Vulnerable | DotNetNuke (DNN) |
| cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.3:*:*:*:*:*:*:* | 5.1.3 | Vulnerable | DotNetNuke (DNN) |
| cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.4:*:*:*:*:*:*:* | 5.1.4 | Vulnerable | DotNetNuke (DNN) |
- cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.1:*:*:*:*:*:*:* Versions 5.1.1 Vulnerable ·DotNetNuke (DNN)
- cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.2:*:*:*:*:*:*:* Versions 5.1.2 Vulnerable ·DotNetNuke (DNN)
- cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.3:*:*:*:*:*:*:* Versions 5.1.3 Vulnerable ·DotNetNuke (DNN)
- cpe:2.3:a:dnnsoftware:dotnetnuke:5.1.4:*:*:*:*:*:*:* Versions 5.1.4 Vulnerable ·DotNetNuke (DNN)
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2009-4110
- 2026-10-03 Alias added: GHSA-26ww-33qp-73qr
References
More DotNetNuke (DNN) Dotnetnuke vulnerabilities
- TI-2017-07201 Code injection in DotNetNuke CMS Fixed in 9.1.1 KEVCVSS 3.1HIGH 8.8
- TI-2018-12944 DNN (aka DotNetNuke) 9.2 through 9.2.2 uses a weak encryption algorithm to protect input… KEVCVSS 3.1HIGH 7.5
- TI-2018-11271 DNN (aka DotNetNuke) 9.2 through 9.2.1 uses a weak encryption algorithm to protect input parameters. KEVCVSS 3.1HIGH 7.5
- TI-2015-02468 The installation wizard in DotNetNuke (DNN) before 7.4.1 allows remote attackers to… CVSS 3.0CRITICAL 9.8
- TI-2025-39546 DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite CVSS 3.1CRITICAL 10.0
- TI-2018-12945 DNN (aka DotNetNuke) 9.2 through 9.2.2 incorrectly converts encryption key source values… CVSS 3.1HIGH 7.5
Sources
- CVE-2009-4110 · CVE Program
- CVE-2009-4110 · NVD
- FIRST EPSS
- GHSA-26ww-33qp-73qr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences