Cross-site scripting (XSS) vulnerability in ZMI pages that use the manage_tabs_message in…
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in ZMI pages that use the manage_tabs_message in Zope 2.11.4, 2.11.2, 2.10.9, 2.10.7, 2.10.6, 2.10.5, 2.10.4, 2.10.2, 2.10.1, 2.12.
Why it matters now
EPSS 0.02072 81st percentileScored 2026-11-07
Fix Partial Zope2 (PyPI): 2.12.5Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Zope2 (PyPI) | before 2.12.5 | 2.12.5 | Patch available | GHSA-5r4x-qc7q-vj27 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Zope2 (PyPI) Vendor— Affected before 2.12.5 Fixed in 2.12.5 Patch available GHSA-5r4x-qc7q-vj27
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zope:zope:2.10.1:*:*:*:*:*:*:* | 2.10.1 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.10.2:*:*:*:*:*:*:* | 2.10.2 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.10.4:*:*:*:*:*:*:* | 2.10.4 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.10.5:*:*:*:*:*:*:* | 2.10.5 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.10.6:*:*:*:*:*:*:* | 2.10.6 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.10.7:*:*:*:*:*:*:* | 2.10.7 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.10.9:*:*:*:*:*:*:* | 2.10.9 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.11.2:*:*:*:*:*:*:* | 2.11.2 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.11.4:*:*:*:*:*:*:* | 2.11.4 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:2.12.0:*:*:*:*:*:*:* | 2.12.0 | Vulnerable | zopefoundation |
- cpe:2.3:a:zope:zope:2.10.1:*:*:*:*:*:*:* Versions 2.10.1 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.10.2:*:*:*:*:*:*:* Versions 2.10.2 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.10.4:*:*:*:*:*:*:* Versions 2.10.4 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.10.5:*:*:*:*:*:*:* Versions 2.10.5 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.10.6:*:*:*:*:*:*:* Versions 2.10.6 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.10.7:*:*:*:*:*:*:* Versions 2.10.7 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.10.9:*:*:*:*:*:*:* Versions 2.10.9 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.11.2:*:*:*:*:*:*:* Versions 2.11.2 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.11.4:*:*:*:*:*:*:* Versions 2.11.4 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:2.12.0:*:*:*:*:*:*:* Versions 2.12.0 Vulnerable ·zopefoundation
Remediation
- Fix · GHSA-5r4x-qc7q-vj27 Zope2 (PyPI) Fixed in 2.12.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2009-5145
- 2026-10-03 Alias added: GHSA-5r4x-qc7q-vj27
References
Advisory 6
- https://bugs.launchpad.net/zope2/+bug/490514
- [oss-security] 20150302 Re: XSS In Zope
- http://cve.killedkenny.io/cve/CVE-2009-5145
- https://github.com/zopefoundation/Zope/commit/2abdf14620f146857dc8e3ffd2b6a754884c331d
- https://security-tracker.debian.org/tracker/CVE-2009-5145/
- https://nvd.nist.gov/vuln/detail/CVE-2009-5145
More zopefoundation Zope vulnerabilities
- TI-2011-03162 Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through… CVSS 2.0HIGH 9.3
- TI-2000-00062 The DTML implementation in the Z Object Publishing Environment (Zope) allows remote… CVSS 2.0HIGH 10.0
- TI-2021-12302 Remote Code Execution via traversal in TAL expressions CVSS 3.1HIGH 8.8
- TI-2021-12342 Remote Code Execution via traversal in TAL expressions CVSS 3.1HIGH 8.8
- TI-2005-03148 docutils in Zope 2.6, 2.7 before 2.7.8, and 2.8 before 2.8.2 allows remote attackers to… CVSS 2.0HIGH 7.5
- TI-2000-00483 The DocumentTemplate package in Zope 2.2 and earlier allows a remote attacker to modify… CVSS 2.0HIGH 7.5
Sources
- CVE-2009-5145 · CVE Program
- CVE-2009-5145 · NVD
- FIRST EPSS
- GHSA-5r4x-qc7q-vj27 · GitHub Advisory Database · CC BY 4.0
- CVE-2009-5145 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences