Cross-site scripting (XSS) vulnerability in createDestination.action in Apache ActiveMQ…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in createDestination.action in Apache ActiveMQ before 5.3.1 allows remote authenticated users to inject arbitrary web script or HTML via the JMSDestination parameter in a queue action.
Why it matters now
EPSS 0.04267 91st percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed org.apache.activemq:activemq-parent (Maven): 5.3.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.activemq:activemq-parent (Maven) | before 5.3.1 | 5.3.1 | Patch available | GHSA-mxf7-pv8q-294h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.activemq:activemq-parent (Maven) Vendor— Affected before 5.3.1 Fixed in 5.3.1 Patch available GHSA-mxf7-pv8q-294h
CPE configurations NVD · 23
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* | up to 5.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:1.1:*:*:*:*:*:*:* | 1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:1.2:*:*:*:*:*:*:* | 1.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:1.3:*:*:*:*:*:*:* | 1.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:1.4:*:*:*:*:*:*:* | 1.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:1.5:*:*:*:*:*:*:* | 1.5 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:2.0:*:*:*:*:*:*:* | 2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:2.1:*:*:*:*:*:*:* | 2.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:3.0:*:*:*:*:*:*:* | 3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:3.1:*:*:*:*:*:*:* | 3.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* Versions up to 5.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:1.1:*:*:*:*:*:*:* Versions 1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:1.2:*:*:*:*:*:*:* Versions 1.2 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:1.3:*:*:*:*:*:*:* Versions 1.3 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:1.4:*:*:*:*:*:*:* Versions 1.4 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:1.5:*:*:*:*:*:*:* Versions 1.5 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:2.1:*:*:*:*:*:*:* Versions 2.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:3.1:*:*:*:*:*:*:* Versions 3.1 Vulnerable ·Apache
Show 13 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:activemq:3.2:*:*:*:*:*:*:* | 3.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:3.2.1:*:*:*:*:*:*:* | 3.2.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:3.2.2:*:*:*:*:*:*:* | 3.2.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:4.0:*:*:*:*:*:*:* | 4.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:4.0:m4:*:*:*:*:*:* | 4.0 m4 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:4.0:rc2:*:*:*:*:*:* | 4.0 rc2 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:4.0.1:*:*:*:*:*:*:* | 4.0.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:4.0.2:*:*:*:*:*:*:* | 4.0.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:4.1.0:*:*:*:*:*:*:* | 4.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:4.1.1:*:*:*:*:*:*:* | 4.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.0.0:*:*:*:*:*:*:* | 5.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.1.0:*:*:*:*:*:*:* | 5.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:activemq:5.2.0:*:*:*:*:*:*:* | 5.2.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:activemq:3.2:*:*:*:*:*:*:* Versions 3.2 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:3.2.2:*:*:*:*:*:*:* Versions 3.2.2 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:4.0:m4:*:*:*:*:*:* Versions 4.0 m4 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:4.0:rc2:*:*:*:*:*:* Versions 4.0 rc2 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:4.1.1:*:*:*:*:*:*:* Versions 4.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.0.0:*:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.1.0:*:*:*:*:*:*:* Versions 5.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:activemq:5.2.0:*:*:*:*:*:*:* Versions 5.2.0 Vulnerable ·Apache
Remediation
- Fix · GHSA-mxf7-pv8q-294h org.apache.activemq:activemq-parent (Maven) Fixed in 5.3.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2010-0684
- 2026-10-03 Alias added: GHSA-mxf7-pv8q-294h
References
Exploit 3
Other 8
- https://github.com/apache/activemq/commit/1f464b9412e1b1c08d40c8ffac40edd52731da48
- https://github.com/apache/activemq/commit/2895197d0dad246757d8d1d9eea181cbf0543ae9
- https://github.com/apache/activemq/commit/fed39c3619825bd92990cf1aa7a4e85119e00a6e
- https://github.com/apache/activemq
- https://web.archive.org/web/20100407054019/http://secunia.com/advisories/39223
- https://web.archive.org/web/20101221101403/http://securitytracker.com/alerts/2010/Mar/1023778.html
- https://web.archive.org/web/20200228042520/http://www.securityfocus.com/bid/39119
- https://web.archive.org/web/20201130115007/http://www.securityfocus.com/archive/1/510419/100/0/threaded
More Apache Activemq vulnerabilities
- TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
- TI-2016-02587 The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-26494 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans KEVCVSS 3.1HIGH 8.8
- TI-2013-05951 Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not… CVSS 3.1CRITICAL 9.8
- TI-2021-04451 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.1
- TI-2021-04446 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
Sources
- CVE-2010-0684 · CVE Program
- CVE-2010-0684 · NVD
- FIRST EPSS
- GHSA-mxf7-pv8q-294h · GitHub Advisory Database · CC BY 4.0
- CVE-2010-0684 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences