Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.
Why it matters now
EPSS 0.01813 78th percentileScored 2026-11-07
Fix Fixed apereo/phpcas (Packagist): 1.1.0moodle/moodle (Packagist): 1.8.12, 1.9.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | apereo/phpcas (Packagist) | before 1.1.0 | 1.1.0 | Patch available | GHSA-45ch-hxgr-vx8j |
| — | moodle/moodle (Packagist) | 1.8.0 to before 1.8.12 | 1.8.12 | Patch available | GHSA-45ch-hxgr-vx8j |
| — | moodle/moodle (Packagist) | 1.9.0 to before 1.9.8 | 1.9.8 | Patch available | GHSA-45ch-hxgr-vx8j |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- apereo/phpcas (Packagist) Vendor— Affected before 1.1.0 Fixed in 1.1.0 Patch available GHSA-45ch-hxgr-vx8j
- moodle/moodle (Packagist) Vendor— Affected 1.8.0 to before 1.8.12 Fixed in 1.8.12 Patch available GHSA-45ch-hxgr-vx8j
- moodle/moodle (Packagist) Vendor— Affected 1.9.0 to before 1.9.8 Fixed in 1.9.8 Patch available GHSA-45ch-hxgr-vx8j
CPE configurations NVD · 20
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ja-sig:phpcas_client_library:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | Ja-sig |
| cpe:2.3:a:ja-sig:phpcas_client_library:1.0.1:*:*:*:*:*:*:* | 1.0.1 | Vulnerable | Ja-sig |
| cpe:2.3:a:moodle:moodle:1.8.1:*:*:*:*:*:*:* | 1.8.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.2:*:*:*:*:*:*:* | 1.8.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.3:*:*:*:*:*:*:* | 1.8.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.4:*:*:*:*:*:*:* | 1.8.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.5:*:*:*:*:*:*:* | 1.8.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.6:*:*:*:*:*:*:* | 1.8.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.7:*:*:*:*:*:*:* | 1.8.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.8:*:*:*:*:*:*:* | 1.8.8 | Vulnerable | Moodle |
- cpe:2.3:a:ja-sig:phpcas_client_library:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Ja-sig
- cpe:2.3:a:ja-sig:phpcas_client_library:1.0.1:*:*:*:*:*:*:* Versions 1.0.1 Vulnerable ·Ja-sig
- cpe:2.3:a:moodle:moodle:1.8.1:*:*:*:*:*:*:* Versions 1.8.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.2:*:*:*:*:*:*:* Versions 1.8.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.3:*:*:*:*:*:*:* Versions 1.8.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.4:*:*:*:*:*:*:* Versions 1.8.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.5:*:*:*:*:*:*:* Versions 1.8.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.6:*:*:*:*:*:*:* Versions 1.8.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.7:*:*:*:*:*:*:* Versions 1.8.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.8:*:*:*:*:*:*:* Versions 1.8.8 Vulnerable ·Moodle
Show 10 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:1.8.9:*:*:*:*:*:*:* | 1.8.9 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.10:*:*:*:*:*:*:* | 1.8.10 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.11:*:*:*:*:*:*:* | 1.8.11 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.1:*:*:*:*:*:*:* | 1.9.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.2:*:*:*:*:*:*:* | 1.9.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.3:*:*:*:*:*:*:* | 1.9.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.4:*:*:*:*:*:*:* | 1.9.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.5:*:*:*:*:*:*:* | 1.9.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.6:*:*:*:*:*:*:* | 1.9.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.7:*:*:*:*:*:*:* | 1.9.7 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:1.8.9:*:*:*:*:*:*:* Versions 1.8.9 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.10:*:*:*:*:*:*:* Versions 1.8.10 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.11:*:*:*:*:*:*:* Versions 1.8.11 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.1:*:*:*:*:*:*:* Versions 1.9.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.2:*:*:*:*:*:*:* Versions 1.9.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.3:*:*:*:*:*:*:* Versions 1.9.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.4:*:*:*:*:*:*:* Versions 1.9.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.5:*:*:*:*:*:*:* Versions 1.9.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.6:*:*:*:*:*:*:* Versions 1.9.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.7:*:*:*:*:*:*:* Versions 1.9.7 Vulnerable ·Moodle
Remediation
- Fix · GHSA-45ch-hxgr-vx8j apereo/phpcas (Packagist) Fixed in 1.1.0 Advisory →
- Fix · GHSA-45ch-hxgr-vx8j moodle/moodle (Packagist) Fixed in 1.8.12 Advisory →
- Fix · GHSA-45ch-hxgr-vx8j moodle/moodle (Packagist) Fixed in 1.9.8 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2010-1618
- 2026-10-03 Alias added: GHSA-45ch-hxgr-vx8j
References
Advisory 3
Sources
- CVE-2010-1618 · CVE Program
- CVE-2010-1618 · NVD
- FIRST EPSS
- GHSA-45ch-hxgr-vx8j · GitHub Advisory Database · CC BY 4.0
- CVE-2010-1618 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences