Priority HIGH 82
The referrer URL used by MFA required additional sanitizing, rather than being used directly.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00545 · Published 2024-05-31 · Fixed in 4.3.4 CWE-20
Priority HIGH 81
In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.52299 · Published 2023-03-06 · Fixed in 3.11.1, 3.10.5 +1 CWE-89
Priority HIGH 79
A flaw was found in Moodle.
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.87536 · Published 2024-11-07 · Fixed in 4.1.12, 4.2.9 +2 CWE-94
Priority HIGH 77
A path traversal vulnerability exists in the Moodle LMS Jmol plugin version 6.1 and prior via the query parameter in jsmol.php.
CVSS 4.0HIGH 8.7· Network · No auth · No interaction · EPSS 0.03057 · Published 2025-06-24 · No fix listed CWE-22
Priority HIGH 72
Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified vectors, related to a "SQL Injection" issue affecting the Administration panel function in the installation process component.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.02247 · Published 2016-10-28 · No fix listed CWE-89
Priority HIGH 66
A flaw was found in Moodle in versions 3.11 to 3.11.4.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.32094 · Published 2022-01-25 · Fixed in 3.11.5 CWE-89
Priority HIGH 65
The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.53652 · Published 2022-07-25 · Fixed in 3.9.15, 3.11.8 +1 CWE-22
Priority MEDIUM 62
An issue was discovered in Moodle 3.x.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.30811 · Published 2018-05-25 · Fixed in 3.1.12, 3.2.9 +2 CWE-94
Priority MEDIUM 60
Virtual Programming Lab for Moodle up to v4.2.3 was discovered to contain a cross-site scripting (XSS) vulnerability via the component vplide.js.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00804 · Published 2024-06-24 · No fix listed CWE-79
Priority MEDIUM 60
A Cross-Site Scripting (XSS) vulnerability exists in the way MOODLE 3.10.9 handles user input within the "GET /?lang=" URL parameter.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00537 · Published 2024-03-21 · No fix listed CWE-79
Priority MEDIUM 60
A command execution vulnerability exists in the default legacy spellchecker plugin in Moodle 3.10.
CVSS 3.1CRITICAL 9.1· Network · High privileges · No interaction · EPSS 0.24173 · Published 2021-06-23 · No fix listed CWE-78
Priority MEDIUM 59
In Moodle, a remote code execution risk was identified in the Shibboleth authentication plugin.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.07034 · Published 2023-03-06 · Fixed in 3.11.1, 3.10.5 +1 CWE-384
Priority MEDIUM 58
Cross Site Scripting vulnerability in Moodle CMS v3.10 allows a remote attacker to execute arbitrary code via the Field Name (name parameter) of a new activity.
CVSS 3.1MEDIUM 5.5· Network · Low privileges · User interaction · EPSS 0.00559 · Published 2024-06-20 · No fix listed CWE-79
Priority MEDIUM 57
In Moodle 2.x and 3.x, SQL injection can occur via user preferences.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.1453 · Published 2017-03-26 · Fixed in 2.7.19, 3.0.9 +2 CWE-89
Priority MEDIUM 56
A reflected cross-site scripting (XSS) vulnerability exists in the Moodle LMS Jmol plugin version 6.1 and prior via the data parameter in jsmol.php.
CVSS 4.0MEDIUM 5.1· Network · No auth · User interaction · EPSS 0.0078 · Published 2025-06-24 · No fix listed CWE-79
Priority MEDIUM 56
Moodle LMS 4.0 contains a cross-site scripting vulnerability that allows unauthenticated attackers to inject malicious scripts by submitting payloads through the search parameter.
CVSS 4.0MEDIUM 5.1· Network · No auth · User interaction · EPSS 0.00305 · Published 2026-05-10 · No fix listed CWE-79
Priority MEDIUM 56
Moodle 3.10.3 contains a persistent cross-site scripting vulnerability in the calendar event subtitle field that allows attackers to inject malicious scripts.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00377 · Published 2026-01-21 · No fix listed CWE-79
Priority MEDIUM 54
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, teachers of a course were able to assign themselves the manager role within that course.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.15993 · Published 2022-08-16 · Fixed in 3.9.1, 3.8.4 +2 CWE-863
Priority MEDIUM 53
A session fixation vulnerability in Moodle 3.x through 3.11.18 allows unauthenticated attackers to hijack user sessions via the sesskey parameter.
CVSS 3.1MEDIUM 4.2· Network · No auth · User interaction · EPSS 0.0037 · Published 2025-06-24 · Fixed in 4.0.0 CWE-384
Priority MEDIUM 53
Authenticated users were able to enumerate other users' names via the learning plans page.
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.00551 · Published 2023-03-23 · Fixed in 4.1.2, 4.0.7 +2 CWE-200
Priority MEDIUM 53
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02101 · Published 2022-09-30 · Fixed in 3.9.17, 3.11.10 +1 CWE-502
Priority MEDIUM 53
The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.08554 · Published 2022-07-25 · Fixed in 3.9.15, 3.11.8 +1 CWE-94
Priority MEDIUM 51
The Mustache pix helper contained a potential Mustache injection risk if combined with user input (note: This did not appear to be implemented/exploitable anywhere in the core Moodle LMS).
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01166 · Published 2023-03-23 · Fixed in 4.1.2, 4.0.7 +2 CWE-94
Priority MEDIUM 51
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the Moodle webroot could utilise a local file inc…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01619 · Published 2023-11-09 · Fixed in 4.2.3, 4.1.6 +4 CWE-94
Priority MEDIUM 51
A limited SQL injection risk was identified in the "browse list of users" site administration page.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01112 · Published 2022-09-30 · Fixed in 3.9.17, 3.11.10 +1 CWE-89
Load more