Improper access control in Apache Derby
Priority LOW 39CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
In Apache Derby 10.1.2.1, 10.2.2.0, 10.3.1.4, and 10.4.1.3, Export processing may allow an attacker to overwrite an existing file.
Why it matters now
EPSS 0.03797 90th percentileScored 2026-11-07
Fix Fixed org.apache.derby:derby (Maven): 10.4.2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Derby | 10.1.2.1, 10.2.2.0, 10.3.1.4, 10.4.1.3 | — | No fix listed | CNA |
| — | org.apache.derby:derby (Maven) | 10.1.2.1 to before 10.4.2.0 | 10.4.2.0 | Patch available | GHSA-xprw-xvvm-vqmv |
- Apache Derby VendorApache Affected 10.1.2.1, 10.2.2.0, 10.3.1.4, 10.4.1.3 Fixed in — No fix listed CNA
- org.apache.derby:derby (Maven) Vendor— Affected 10.1.2.1 to before 10.4.2.0 Fixed in 10.4.2.0 Patch available GHSA-xprw-xvvm-vqmv
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:derby:10.1.2.1:*:*:*:*:*:*:* | 10.1.2.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.2.2.0:*:*:*:*:*:*:* | 10.2.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.3.1.4:*:*:*:*:*:*:* | 10.3.1.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.4.1.3:*:*:*:*:*:*:* | 10.4.1.3 | Vulnerable | Apache |
- cpe:2.3:a:apache:derby:10.1.2.1:*:*:*:*:*:*:* Versions 10.1.2.1 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.2.2.0:*:*:*:*:*:*:* Versions 10.2.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.3.1.4:*:*:*:*:*:*:* Versions 10.3.1.4 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.4.1.3:*:*:*:*:*:*:* Versions 10.4.1.3 Vulnerable ·Apache
Remediation
- Fix · GHSA-xprw-xvvm-vqmv org.apache.derby:derby (Maven) Fixed in 10.4.2.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat BPM Suite 6
- Red Hat JBoss BRMS 5
- Red Hat JBoss BRMS 6
- Red Hat JBoss Fuse 6
- Red Hat Single Sign-On 7
Timeline
- 2026-10-02 Threatist record created from CVE-2010-2232
- 2026-10-03 Alias added: GHSA-xprw-xvvm-vqmv
- 2026-11-03 EPSS moved to the 90th–95th percentile
References
More Apache Derby vulnerabilities
- TI-2015-01645 XML external entity (XXE) vulnerability in the SqlXmlUtil code in Apache Derby before… CVSS 3.0CRITICAL 9.1
- TI-2022-22882 Apache Derby: LDAP injection vulnerability in authenticator CVSS 3.1CRITICAL 9.8
- TI-2018-01216 Improper access control in Apache Derby CVSS 3.1MEDIUM 5.3
- TI-2005-04579 Apache Derby before 10.1.2.1 exposes the (1) user and (2) password attributes in… CVSS 2.0MEDIUM 5.0
- TI-2006-06958 Apache Derby before 10.2.1.6 does not determine schema privilege requirements during the… CVSS 2.0MEDIUM 4.0
- TI-2006-06957 Apache Derby before 10.2.1.6 does not determine privilege requirements for lock table… CVSS 2.0MEDIUM 4.0
Sources
- CVE-2010-2232 · CVE Program
- CVE-2010-2232 · NVD
- FIRST EPSS
- GHSA-xprw-xvvm-vqmv · GitHub Advisory Database · CC BY 4.0
- CVE-2010-2232 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences