XML external entity (XXE) vulnerability in the SqlXmlUtil code in Apache Derby before…
Priority MEDIUM 53CWE-399Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
XML external entity (XXE) vulnerability in the SqlXmlUtil code in Apache Derby before 10.12.1.1, when a Java Security Manager is not in place, allows context-dependent attackers to read arbitrary files or cause a denial of service (resource consumption) via vectors involving XmlVTI and the XML datatype.
Why it matters now
EPSS 0.12173 96th percentileScored 2026-11-07
Fix Fixed org.apache.derby:derby (Maven): 10.12.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.derby:derby (Maven) | before 10.12.1.1 | 10.12.1.1 | Patch available | GHSA-wr69-g62g-2r9h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.derby:derby (Maven) Vendor— Affected before 10.12.1.1 Fixed in 10.12.1.1 Patch available GHSA-wr69-g62g-2r9h
CPE configurations NVD · 20
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:derby:10.1.1.0:*:*:*:*:*:*:* | 10.1.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.1.2.1:*:*:*:*:*:*:* | 10.1.2.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.1.3.1:*:*:*:*:*:*:* | 10.1.3.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.2.1.6:*:*:*:*:*:*:* | 10.2.1.6 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.2.2.0:*:*:*:*:*:*:* | 10.2.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.3.3.0:*:*:*:*:*:*:* | 10.3.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.4.1.3:*:*:*:*:*:*:* | 10.4.1.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.4.2.0:*:*:*:*:*:*:* | 10.4.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.5.1.1:*:*:*:*:*:*:* | 10.5.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.5.3.0:*:*:*:*:*:*:* | 10.5.3.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:derby:10.1.1.0:*:*:*:*:*:*:* Versions 10.1.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.1.2.1:*:*:*:*:*:*:* Versions 10.1.2.1 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.1.3.1:*:*:*:*:*:*:* Versions 10.1.3.1 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.2.1.6:*:*:*:*:*:*:* Versions 10.2.1.6 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.2.2.0:*:*:*:*:*:*:* Versions 10.2.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.3.3.0:*:*:*:*:*:*:* Versions 10.3.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.4.1.3:*:*:*:*:*:*:* Versions 10.4.1.3 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.4.2.0:*:*:*:*:*:*:* Versions 10.4.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.5.1.1:*:*:*:*:*:*:* Versions 10.5.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.5.3.0:*:*:*:*:*:*:* Versions 10.5.3.0 Vulnerable ·Apache
Show 10 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:derby:10.6.1.0:*:*:*:*:*:*:* | 10.6.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.6.2.1:*:*:*:*:*:*:* | 10.6.2.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.7.1.1:*:*:*:*:*:*:* | 10.7.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.8.1.2:*:*:*:*:*:*:* | 10.8.1.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.8.2.2:*:*:*:*:*:*:* | 10.8.2.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.8.3.0:*:*:*:*:*:*:* | 10.8.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.9.1.0:*:*:*:*:*:*:* | 10.9.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.10.1.1:*:*:*:*:*:*:* | 10.10.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.10.2.0:*:*:*:*:*:*:* | 10.10.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:derby:10.11.1.1:*:*:*:*:*:*:* | 10.11.1.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:derby:10.6.1.0:*:*:*:*:*:*:* Versions 10.6.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.6.2.1:*:*:*:*:*:*:* Versions 10.6.2.1 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.7.1.1:*:*:*:*:*:*:* Versions 10.7.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.8.1.2:*:*:*:*:*:*:* Versions 10.8.1.2 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.8.2.2:*:*:*:*:*:*:* Versions 10.8.2.2 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.8.3.0:*:*:*:*:*:*:* Versions 10.8.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.9.1.0:*:*:*:*:*:*:* Versions 10.9.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.10.1.1:*:*:*:*:*:*:* Versions 10.10.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.10.2.0:*:*:*:*:*:*:* Versions 10.10.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:derby:10.11.1.1:*:*:*:*:*:*:* Versions 10.11.1.1 Vulnerable ·Apache
Remediation
- Fix · GHSA-wr69-g62g-2r9h org.apache.derby:derby (Maven) Fixed in 10.12.1.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 3 products
- Red Hat BPM Suite 6
- Red Hat JBoss BRMS 6
- Red Hat JBoss Fuse 6
Timeline
- 2026-10-02 Threatist record created from CVE-2015-1832
- 2026-10-03 Alias added: GHSA-wr69-g62g-2r9h
References
Advisory 2
Other 16
- [lucene-solr-user] 20190104 Re: SOLR v7 Security Issues Caused Denial of Use - Sonatype Application Composition Report
- [drill-dev] 20191017 Dependencies used by Drill contain known vulnerabilities
- [drill-dev] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilities
- [drill-issues] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilities
- [lucene-solr-user] 20200320 CVEs (vulnerabilities) that apply to Solr 8.4.1
- https://www.oracle.com/security-alerts/cpuapr2020.html
- https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html
- https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
- https://www.oracle.com/security-alerts/cpuoct2020.html
- https://issues.apache.org/jira/browse/DERBY-6807
- https://svn.apache.org/viewvc?view=revision&revision=1691461
- https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f@%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/708d94141126eac03011144a971a6411fcac16d9c248d1d535a39451@%3Csolr-user.lucene.apache.org%3E
- https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442@%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc@%3Cissues.drill.apache.org%3E
- https://lists.apache.org/thread.html/r204ba2a9ea750f38d789d2bb429cc0925ad6133deea7cbc3001d96b5@%3Csolr-user.lucene.apache.org%3E
More Apache Derby vulnerabilities
- TI-2022-22882 Apache Derby: LDAP injection vulnerability in authenticator CVSS 3.1CRITICAL 9.8
- TI-2010-02141 Improper access control in Apache Derby CVSS 3.0HIGH 7.5
- TI-2018-01216 Improper access control in Apache Derby CVSS 3.1MEDIUM 5.3
- TI-2005-04579 Apache Derby before 10.1.2.1 exposes the (1) user and (2) password attributes in… CVSS 2.0MEDIUM 5.0
- TI-2006-06958 Apache Derby before 10.2.1.6 does not determine schema privilege requirements during the… CVSS 2.0MEDIUM 4.0
- TI-2006-06957 Apache Derby before 10.2.1.6 does not determine privilege requirements for lock table… CVSS 2.0MEDIUM 4.0
Sources
- CVE-2015-1832 · CVE Program
- CVE-2015-1832 · NVD
- FIRST EPSS
- GHSA-wr69-g62g-2r9h · GitHub Advisory Database · CC BY 4.0
- CVE-2015-1832 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences