libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which…
Priority LOW 23CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Security bypass, Spoofing
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264 and CWE-295.
Summary
libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM) attack.
Why it matters now
EPSS 0.01379 72nd percentileScored 2026-11-07
Fix Fixed apache-libcloud (PyPI): 0.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | apache-libcloud (PyPI) | before 0.4.0 | 0.4.0 | Patch available | GHSA-w3j6-8j34-q43x |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- apache-libcloud (PyPI) Vendor— Affected before 0.4.0 Fixed in 0.4.0 Patch available GHSA-w3j6-8j34-q43x
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:libcloud:*:*:*:*:*:*:*:* | up to 0.4.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:libcloud:0.2.0:*:*:*:*:*:*:* | 0.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:libcloud:0.3.0:*:*:*:*:*:*:* | 0.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:libcloud:0.3.1:*:*:*:*:*:*:* | 0.3.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:libcloud:*:*:*:*:*:*:*:* Versions up to 0.4.0 Vulnerable ·Apache
- cpe:2.3:a:apache:libcloud:0.2.0:*:*:*:*:*:*:* Versions 0.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:libcloud:0.3.0:*:*:*:*:*:*:* Versions 0.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:libcloud:0.3.1:*:*:*:*:*:*:* Versions 0.3.1 Vulnerable ·Apache
Remediation
- Fix · GHSA-w3j6-8j34-q43x apache-libcloud (PyPI) Fixed in 0.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2010-4340
- 2026-10-03 Alias added: GHSA-w3j6-8j34-q43x
References
Other 10
- [libcloud] 20100929 [jira] Closed: (LIBCLOUD-55) this python project is vulnerable to MITM as it fails to verify the ssl validity of the remote destination.
- http://wiki.apache.org/incubator/LibcloudSSL
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=598463
- [libcloud] 20101108 SSL certs checking
- https://issues.apache.org/jira/browse/LIBCLOUD-55
- https://github.com/apache/libcloud/commit/87ee61e6ba03a43dcefea2ce180988bec066b6fd
- https://bugs.python.org/issue1589
- https://github.com/apache/libcloud
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-libcloud/PYSEC-2011-24.yaml
- http://mail-archives.apache.org/mod_mbox/incubator-libcloud/201009.mbox/%3C5860913.463891285776633273.JavaMail.jira@thor%3E
More Apache Libcloud vulnerabilities
- TI-2012-02974 Apache Libcloud before 0.11.1 uses an incorrect regular expression during verification of… CVSS 3.1MEDIUM 5.9
- TI-2013-05430 Libcloud 0.12.3 through 0.13.2 does not set the scrub_data parameter for the destroy… CVSS 2.0LOW 2.1
Sources
- CVE-2010-4340 · CVE Program
- CVE-2010-4340 · NVD
- FIRST EPSS
- GHSA-w3j6-8j34-q43x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences