Libcloud 0.12.3 through 0.13.2 does not set the scrub_data parameter for the destroy…
Priority LOW 15CWE-200Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Libcloud 0.12.3 through 0.13.2 does not set the scrub_data parameter for the destroy DigitalOcean API, which allows local users to obtain sensitive information by leveraging a new VM.
Why it matters now
EPSS 0.0206 81st percentileScored 2026-11-07
Fix Fixed apache-libcloud (PyPI): 0.13.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | apache-libcloud (PyPI) | 0.12.3 to before 0.13.3 | 0.13.3 | Patch available | GHSA-g892-9h8m-r69r |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- apache-libcloud (PyPI) Vendor— Affected 0.12.3 to before 0.13.3 Fixed in 0.13.3 Patch available GHSA-g892-9h8m-r69r
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:libcloud:0.12.3:*:*:*:*:*:*:* | 0.12.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:libcloud:0.12.4:*:*:*:*:*:*:* | 0.12.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:libcloud:0.13.0:*:*:*:*:*:*:* | 0.13.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:libcloud:0.13.1:*:*:*:*:*:*:* | 0.13.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:libcloud:0.13.2:*:*:*:*:*:*:* | 0.13.2 | Vulnerable | Apache |
- cpe:2.3:a:apache:libcloud:0.12.3:*:*:*:*:*:*:* Versions 0.12.3 Vulnerable ·Apache
- cpe:2.3:a:apache:libcloud:0.12.4:*:*:*:*:*:*:* Versions 0.12.4 Vulnerable ·Apache
- cpe:2.3:a:apache:libcloud:0.13.0:*:*:*:*:*:*:* Versions 0.13.0 Vulnerable ·Apache
- cpe:2.3:a:apache:libcloud:0.13.1:*:*:*:*:*:*:* Versions 0.13.1 Vulnerable ·Apache
- cpe:2.3:a:apache:libcloud:0.13.2:*:*:*:*:*:*:* Versions 0.13.2 Vulnerable ·Apache
Remediation
- Fix · GHSA-g892-9h8m-r69r apache-libcloud (PyPI) Fixed in 0.13.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2013-6480
- 2026-10-03 Alias added: GHSA-g892-9h8m-r69r
References
Advisory 3
Other 10
- https://digitalocean.com/blog_posts/transparency-regarding-data-security
- https://github.com/fog/fog/issues/2525
- https://github.com/apache/libcloud/commit/4449e165a00756dc61430e6ad9520f005b045d29
- https://github.com/apache/libcloud
- https://github.com/apache/libcloud/blob/abba8c1719a8bda6db8efde2d46fd1b423ae4304/CHANGES.rst#compute-48
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-libcloud/PYSEC-2014-97.yaml
- https://issues.apache.org/jira/browse/LIBCLOUD-487
- https://web.archive.org/web/20131230232003/https://digitalocean.com/blog_posts/transparency-regarding-data-security
- https://web.archive.org/web/20140129025443/http://www.securityfocus.com/bid/64617
- https://web.archive.org/web/20201209074449/http://www.securityfocus.com/archive/1/530624/100/0/threaded
More Apache Libcloud vulnerabilities
- TI-2012-02974 Apache Libcloud before 0.11.1 uses an incorrect regular expression during verification of… CVSS 3.1MEDIUM 5.9
- TI-2010-04073 libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2013-6480 · CVE Program
- CVE-2013-6480 · NVD
- FIRST EPSS
- GHSA-g892-9h8m-r69r · GitHub Advisory Database · CC BY 4.0
- CVE-2013-6480 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences