AjaXplorer < 2.6 checkInstall.php Unauthenticated RCE
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-78.
Summary
An unauthenticated remote command execution vulnerability exists in AjaXplorer (now known as Pydio Cells) versions prior to 2.6. The flaw resides in the checkInstall.php script within the access.ssh plugin, which fails to properly sanitize user-supplied input to the destServer GET parameter. By injecting shell metacharacters, remote attackers can execute arbitrary system commands on the server with the privileges of the web server process.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AjaXplorer | AjaXplorer | before 2.6 | 2.6 | Patch available | CNA |
- AjaXplorer VendorAjaXplorer Affected before 2.6 Fixed in 2.6 Patch available CNA
Remediation
- Fix · CNA AjaXplorer (AjaXplorer) Fixed in 2.6
Timeline
- 2026-10-02 Threatist record created from CVE-2010-10013
- 2026-10-03 Alias added: GHSA-6xxj-wqc6-8pq7
References
More AjaXplorer vulnerabilities
- TI-2022-19170 An issue was discovered in AjaXplorer 4.2.3, allows attackers to cause cross site… CVSS 3.1MEDIUM 5.4
- TI-2013-05239 Unrestricted file upload vulnerability in plugins/editor.zoho/agent/save_zoho.php in the… CVSS 2.0HIGH 7.5
- TI-2013-05238 Directory traversal vulnerability in plugins/editor.zoho/agent/save_zoho.php in the Zoho… CVSS 2.0HIGH 8.5
- TI-2012-01623 Multiple directory traversal vulnerabilities in the Get Template feature in… CVSS 2.0HIGH 7.5
- TI-2012-01624 AjaXplorer 3.2.x before 3.2.5 and 4.0.x before 4.0.4 does not properly perform cookie… CVSS 2.0HIGH 7.5
- TI-2013-04844 Multiple directory traversal vulnerabilities in index.php in AjaXplorer 5.0.2 and earlier… CVSS 2.0MEDIUM 5.5
Sources
- CVE-2010-10013 · CVE Program
- CVE-2010-10013 · NVD
- FIRST EPSS
- GHSA-6xxj-wqc6-8pq7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences