Improper input validation in gksu-polkit
Priority MEDIUM 45CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In gksu-polkit before 0.0.3, the source file for xauth may contain arbitrary commands that may allow an attacker to overtake an administrator X11 session.
Why it matters now
EPSS 0.01267 69th percentileScored 2026-11-07
Fix Fixed gksu-polkit (gksu-polkit): 0.0.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| gksu-polkit | gksu-polkit | before 0.0.3 | 0.0.3 | Patch available | CNA |
- gksu-polkit Vendorgksu-polkit Affected before 0.0.3 Fixed in 0.0.3 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gksu-polkit_project:gksu-polkit:*:*:*:*:*:*:*:* | before 0.0.3 | Vulnerable | Gksu-polkit Project |
| cpe:2.3:o:debian:debian_linux:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Debian |
- cpe:2.3:a:gksu-polkit_project:gksu-polkit:*:*:*:*:*:*:*:* Versions before 0.0.3 Vulnerable ·Gksu-polkit Project
- cpe:2.3:o:debian:debian_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Debian
Remediation
- Fix · CNA gksu-polkit (gksu-polkit) Fixed in 0.0.3
Timeline
- 2026-10-02 Threatist record created from CVE-2011-0703
- 2026-10-03 Alias added: GHSA-vrmv-52qc-xvhh
References
Sources
- CVE-2011-0703 · CVE Program
- CVE-2011-0703 · NVD
- FIRST EPSS
- GHSA-vrmv-52qc-xvhh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences