Cross-site scripting (XSS) vulnerability in templatefunctions.py in Loggerhead before…
Priority LOW 20CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in templatefunctions.py in Loggerhead before 1.18.1 allows remote authenticated users to inject arbitrary web script or HTML via a filename, which is not properly handled in a revision view.
Why it matters now
EPSS 0.01829 78th percentileScored 2026-11-07
Fix Fixed loggerhead (PyPI): 1.18.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | loggerhead (PyPI) | before 1.18.1 | 1.18.1 | Patch available | GHSA-qjmg-77xh-7mjw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- loggerhead (PyPI) Vendor— Affected before 1.18.1 Fixed in 1.18.1 Patch available GHSA-qjmg-77xh-7mjw
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:michael_hudson-doyle:loggerhead:*:*:*:*:*:*:*:* | up to 1.18 | Vulnerable | Michael Hudson-doyle |
| cpe:2.3:a:michael_hudson-doyle:loggerhead:1.6:*:*:*:*:*:*:* | 1.6 | Vulnerable | Michael Hudson-doyle |
| cpe:2.3:a:michael_hudson-doyle:loggerhead:1.6.1:*:*:*:*:*:*:* | 1.6.1 | Vulnerable | Michael Hudson-doyle |
| cpe:2.3:a:michael_hudson-doyle:loggerhead:1.10:*:*:*:*:*:*:* | 1.10 | Vulnerable | Michael Hudson-doyle |
| cpe:2.3:a:michael_hudson-doyle:loggerhead:1.17:*:*:*:*:*:*:* | 1.17 | Vulnerable | Michael Hudson-doyle |
- cpe:2.3:a:michael_hudson-doyle:loggerhead:*:*:*:*:*:*:*:* Versions up to 1.18 Vulnerable ·Michael Hudson-doyle
- cpe:2.3:a:michael_hudson-doyle:loggerhead:1.6:*:*:*:*:*:*:* Versions 1.6 Vulnerable ·Michael Hudson-doyle
- cpe:2.3:a:michael_hudson-doyle:loggerhead:1.6.1:*:*:*:*:*:*:* Versions 1.6.1 Vulnerable ·Michael Hudson-doyle
- cpe:2.3:a:michael_hudson-doyle:loggerhead:1.10:*:*:*:*:*:*:* Versions 1.10 Vulnerable ·Michael Hudson-doyle
- cpe:2.3:a:michael_hudson-doyle:loggerhead:1.17:*:*:*:*:*:*:* Versions 1.17 Vulnerable ·Michael Hudson-doyle
Remediation
- Fix · GHSA-qjmg-77xh-7mjw loggerhead (PyPI) Fixed in 1.18.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2011-0728
- 2026-10-03 Alias added: GHSA-qjmg-77xh-7mjw
References
Patch 2
Advisory 4
Sources
- CVE-2011-0728 · CVE Program
- CVE-2011-0728 · NVD
- FIRST EPSS
- GHSA-qjmg-77xh-7mjw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences