Multiple cross-site scripting (XSS) vulnerabilities in component handlers in the…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in component handlers in the javatemplates (aka Java Templates) plugin in Apache Struts 2.x before 2.2.3 allow remote attackers to inject arbitrary web script or HTML via an arbitrary parameter value to a .action URI, related to improper handling of value attributes in (1) FileHandler.java, (2) HiddenHandler.java, (3) PasswordHandler.java, (4) RadioHandler.java, (5) ResetHandler.java, (6) SelectHandler.java, (7) SubmitHandler.java, and (8) TextFieldHandler.java.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.struts:struts2-parent (Maven) | before 2.2.3 | 2.2.3 | Patch available | GHSA-5pgj-r7c6-7c7w |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.struts:struts2-parent (Maven) Vendor— Affected before 2.2.3 Fixed in 2.2.3 Patch available GHSA-5pgj-r7c6-7c7w
CPE configurations NVD · 28
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:struts:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.2:*:*:*:*:*:*:* | 2.0.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.3:*:*:*:*:*:*:* | 2.0.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.4:*:*:*:*:*:*:* | 2.0.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.5:*:*:*:*:*:*:* | 2.0.5 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.6:*:*:*:*:*:*:* | 2.0.6 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.7:*:*:*:*:*:*:* | 2.0.7 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.8:*:*:*:*:*:*:* | 2.0.8 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.9:*:*:*:*:*:*:* | 2.0.9 | Vulnerable | Apache |
- cpe:2.3:a:apache:struts:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.3:*:*:*:*:*:*:* Versions 2.0.3 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.4:*:*:*:*:*:*:* Versions 2.0.4 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.5:*:*:*:*:*:*:* Versions 2.0.5 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.6:*:*:*:*:*:*:* Versions 2.0.6 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.7:*:*:*:*:*:*:* Versions 2.0.7 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.8:*:*:*:*:*:*:* Versions 2.0.8 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.9:*:*:*:*:*:*:* Versions 2.0.9 Vulnerable ·Apache
Show 18 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:struts:2.0.10:*:*:*:*:*:*:* | 2.0.10 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.11:*:*:*:*:*:*:* | 2.0.11 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.11.1:*:*:*:*:*:*:* | 2.0.11.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.11.2:*:*:*:*:*:*:* | 2.0.11.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.12:*:*:*:*:*:*:* | 2.0.12 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.13:*:*:*:*:*:*:* | 2.0.13 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.0.14:*:*:*:*:*:*:* | 2.0.14 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.1.2:*:*:*:*:*:*:* | 2.1.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.1.3:*:*:*:*:*:*:* | 2.1.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.1.4:*:*:*:*:*:*:* | 2.1.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.1.5:*:*:*:*:*:*:* | 2.1.5 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.1.6:*:*:*:*:*:*:* | 2.1.6 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.1.8:*:*:*:*:*:*:* | 2.1.8 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.1.8.1:*:*:*:*:*:*:* | 2.1.8.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.2.1:*:*:*:*:*:*:* | 2.2.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:struts:2.2.1.1:*:*:*:*:*:*:* | 2.2.1.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:struts:2.0.10:*:*:*:*:*:*:* Versions 2.0.10 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.11:*:*:*:*:*:*:* Versions 2.0.11 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.11.1:*:*:*:*:*:*:* Versions 2.0.11.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.11.2:*:*:*:*:*:*:* Versions 2.0.11.2 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.12:*:*:*:*:*:*:* Versions 2.0.12 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.13:*:*:*:*:*:*:* Versions 2.0.13 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.0.14:*:*:*:*:*:*:* Versions 2.0.14 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.1.3:*:*:*:*:*:*:* Versions 2.1.3 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.1.4:*:*:*:*:*:*:* Versions 2.1.4 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.1.5:*:*:*:*:*:*:* Versions 2.1.5 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.1.6:*:*:*:*:*:*:* Versions 2.1.6 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.1.8:*:*:*:*:*:*:* Versions 2.1.8 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.1.8.1:*:*:*:*:*:*:* Versions 2.1.8.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·Apache
- cpe:2.3:a:apache:struts:2.2.1.1:*:*:*:*:*:*:* Versions 2.2.1.1 Vulnerable ·Apache
Remediation
- Fix · GHSA-5pgj-r7c6-7c7w org.apache.struts:struts2-parent (Maven) Fixed in 2.2.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | — |
| Red Hat JBoss Enterprise Web Server 1 | Affected | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2011-2087
- 2026-10-03 Alias added: GHSA-5pgj-r7c6-7c7w
References
More Apache Struts vulnerabilities
- TI-2020-13278 Expression language injection in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-07171 Improper input validation in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2013-02013 Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-00357 The ExceptionDelegator component in Apache Struts before 2.2.3.1 interprets parameter… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-08433 Improper input validation in Apache Struts KEVCVSS 3.1HIGH 8.1
Sources
- CVE-2011-2087 · CVE Program
- CVE-2011-2087 · NVD
- FIRST EPSS
- GHSA-5pgj-r7c6-7c7w · GitHub Advisory Database · CC BY 4.0
- CVE-2011-2087 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences