Polipo before 1.0.4.1 suffers from a DoD vulnerability via specially-crafted HTTP POST / PUT request.
Priority MEDIUM 46CWE-617Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-617.
Summary
Polipo before 1.0.4.1 suffers from a DoD vulnerability via specially-crafted HTTP POST / PUT request.
Why it matters now
EPSS 0.11055 95th percentileScored 2026-11-07
Fix Fixed polipo (polipo): 1.0.4.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| polipo | polipo | before 1.0.4.1 | 1.0.4.1 | Patch available | CNA |
- polipo Vendorpolipo Affected before 1.0.4.1 Fixed in 1.0.4.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:polipo_project:polipo:*:*:*:*:*:*:*:* | before 1.0.4.1 | Vulnerable | Polipo Project |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:polipo_project:polipo:*:*:*:*:*:*:*:* Versions before 1.0.4.1 Vulnerable ·Polipo Project
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA polipo (polipo) Fixed in 1.0.4.1
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2011-3596
- 2026-10-03 Alias added: GHSA-rc34-472p-6fgh
References
More polipo vulnerabilities
- TI-2005-02990 Unspecified vulnerability in Polipo 0.9.8 and earlier allows attackers to read files outside of the web root. CVSS 2.0MEDIUM 5.0
- TI-2007-04478 Unspecified vulnerability in Polipo before 1.0.2 allows remote attackers to cause a… CVSS 2.0MEDIUM 5.0
- TI-2007-04477 Polipo before 1.0.2 allows remote HTTP servers to cause a denial of service (daemon… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2011-3596 · CVE Program
- CVE-2011-3596 · NVD
- FIRST EPSS
- GHSA-rc34-472p-6fgh · GitHub Advisory Database · CC BY 4.0
- CVE-2011-3596 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences