Read the docs
TI-2011-03625 Aliases CVE-2011-4107GHSA-q4mm-89q2-xffg

The simplexml_load_string function in the XML import plug-in (libraries/import/xml.php)…

Priority MEDIUM 43CWE-611Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-611 and the CVSS impact.

Summary

The simplexml_load_string function in the XML import plug-in (libraries/import/xml.php) in phpMyAdmin 3.4.x before 3.4.7.1 and 3.3.x before 3.3.10.5 allows remote authenticated users to read arbitrary files via XML data containing external entity references, aka an XML external entity (XXE) injection attack.

Why it matters now

EPSS 0.12679 96th percentileScored 2026-11-07
Public exploit Yes 4 exploit referencesTagged by NVD
Fix Fixed phpmyadmin/phpmyadmin (Packagist): 3.4.7.1, 3.3.10.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—phpmyadmin/phpmyadmin (Packagist)3.4.0 to before 3.4.7.13.4.7.1Patch availableGHSA-q4mm-89q2-xffg
—phpmyadmin/phpmyadmin (Packagist)3.3.0 to before 3.3.10.53.3.10.5Patch availableGHSA-q4mm-89q2-xffg
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 3.4.0 to before 3.4.7.1 Fixed in 3.4.7.1 Patch available GHSA-q4mm-89q2-xffg
  • phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 3.3.0 to before 3.3.10.5 Fixed in 3.3.10.5 Patch available GHSA-q4mm-89q2-xffg

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*3.3.0.0 to before 3.3.10.5; 3.4.0.0 to before 3.4.7.1VulnerablephpMyAdmin
cpe:2.3:o:fedoraproject:fedora:14:*:*:*:*:*:*:*14VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:15:*:*:*:*:*:*:*15VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:16:*:*:*:*:*:*:*16VulnerableFedoraproject
cpe:2.3:o:debian:debian_linux:5.0:*:*:*:*:*:*:*5.0VulnerableDebian
  • cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* Versions 3.3.0.0 to before 3.3.10.5; 3.4.0.0 to before 3.4.7.1 Vulnerable ·phpMyAdmin
  • cpe:2.3:o:fedoraproject:fedora:14:*:*:*:*:*:*:* Versions 14 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:15:*:*:*:*:*:*:* Versions 15 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:16:*:*:*:*:*:*:* Versions 16 Vulnerable ·Fedoraproject
  • cpe:2.3:o:debian:debian_linux:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-q4mm-89q2-xffg phpmyadmin/phpmyadmin (Packagist) Fixed in 3.4.7.1 Advisory →
  • Fix · GHSA-q4mm-89q2-xffg phpmyadmin/phpmyadmin (Packagist) Fixed in 3.3.10.5 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2011-4107
  2. 2026-10-03 Alias added: GHSA-q4mm-89q2-xffg

References

Sources