Read the docs
TI-2011-03809 Aliases CVE-2011-4344GHSA-q3rp-555r-hh6r

Cross-site scripting (XSS) vulnerability in Jenkins Core in Jenkins before 1.438, and…

Priority LOW 16CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
High
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in Jenkins Core in Jenkins before 1.438, and 1.409 LTS before 1.409.3 LTS, when a stand-alone container is used, allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Why it matters now

EPSS 0.01231 69th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 1.409.3, 1.438

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)before 1.409.31.409.3Patch availableGHSA-q3rp-555r-hh6r
—org.jenkins-ci.main:jenkins-core (Maven)1.410 to before 1.4381.438Patch availableGHSA-q3rp-555r-hh6r
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 1.409.3 Fixed in 1.409.3 Patch available GHSA-q3rp-555r-hh6r
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.410 to before 1.438 Fixed in 1.438 Patch available GHSA-q3rp-555r-hh6r

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:1.409.1:*:*:*:lts:*:*:*1.409.1VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:1.409.2:*:*:*:lts:*:*:*1.409.2VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:*up to 1.437VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:1.409.1:*:*:*:lts:*:*:* Versions 1.409.1 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:1.409.2:*:*:*:lts:*:*:* Versions 1.409.2 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* Versions up to 1.437 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-q3rp-555r-hh6r org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.409.3 Advisory →
  • Fix · GHSA-q3rp-555r-hh6r org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.438 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2011-4344
  2. 2026-10-03 Alias added: GHSA-q3rp-555r-hh6r

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources