Path traversal in Jenkins
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 3 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat.
Summary
Jenkins 2.441 and earlier, LTS 2.426.2 and earlier does not disable a feature of its CLI command parser that replaces an '@' character followed by a file path in an argument with the file's contents, allowing unauthenticated attackers to read arbitrary files on the Jenkins controller file system.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins | — | 2.442, 2.426.3, 2.440.1 | Patch available | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 1.606 to before 2.426.3 | 2.426.3 | Patch available | GHSA-6f9g-cxwr-q5jr |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.427 to before 2.440.1 | 2.440.1 | Patch available | GHSA-6f9g-cxwr-q5jr |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.441 to before 2.442 | 2.442 | Patch available | GHSA-6f9g-cxwr-q5jr |
- Jenkins VendorJenkins Affected — Fixed in 2.442, 2.426.3, 2.440.1 Patch available CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.606 to before 2.426.3 Fixed in 2.426.3 Patch available GHSA-6f9g-cxwr-q5jr
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.427 to before 2.440.1 Fixed in 2.440.1 Patch available GHSA-6f9g-cxwr-q5jr
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.441 to before 2.442 Fixed in 2.442 Patch available GHSA-6f9g-cxwr-q5jr
Remediation
- Fix · CNA Jenkins (Jenkins Project) Fixed in 2.442, 2.426.3, 2.440.1
- Fix · GHSA-6f9g-cxwr-q5jr org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.426.3 Advisory →
- Fix · GHSA-6f9g-cxwr-q5jr org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.440.1 Advisory →
- Fix · GHSA-6f9g-cxwr-q5jr org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.442 Advisory →
Red Hat 3 advisories
- RHSA-2024:0775 Released 2024-02-12 · Red Hat rating Importantjenkins and jenkins-2-plugins security update
- OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8 jenkins-2-plugins-4.11.1706516946-1.el8, jenkins-2.426.3.1706516929-3.el8
- RHSA-2024:0778 Released 2024-02-12 · Red Hat rating ImportantJenkins and Jenkins-2-plugins security update
- OpenShift Developer Tools and Services for OCP 4.12 jenkins-2-plugins-4.12.1706515741-1.el8, jenkins-2.426.3.1706515686-3.el8
- RHSA-2024:0776 Released 2024-02-12 · Red Hat rating Importantjenkins and jenkins-2-plugins security update
- OpenShift Developer Tools and Services for OCP 4.13 jenkins-2-plugins-4.13.1706516346-1.el8, jenkins-2.426.3.1706516254-3.el8
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Jenkins — Jenkins Security Advisory 2024-01-24
2 records Highest priority Priority CRITICAL 1 CRITICAL, 1 HIGH
Other records, highest priority first
- TI-2024-15886 Origin validation error in JenkinsPriority HIGH 77
Vendor assessments
Red Hat
Red Hat rating: Critical. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Out of support scope |
| OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8 | Fixed | RHSA-2024:0775 |
| OpenShift Developer Tools and Services for OCP 4.12 | Fixed | RHSA-2024:0778 |
| OpenShift Developer Tools and Services for OCP 4.13 | Fixed | RHSA-2024:0776 |
Not affected: 3 products
- OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8
- OpenShift Developer Tools and Services for OCP 4.12
- OpenShift Developer Tools and Services for OCP 4.13
Timeline
- 2024-08-19 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2024-23897
- 2026-10-03 Alias added: GHSA-6f9g-cxwr-q5jr
References
Exploit 3
- https://www.sonarsource.com/blog/excessive-expansion-uncovering-critical-security-vulnerabilities-in-jenkins/
- http://packetstormsecurity.com/files/176840/Jenkins-2.441-LTS-2.426.3-Arbitrary-File-Read.html
- https://www.vicarius.io/vsociety/posts/the-anatomy-of-a-jenkins-vulnerability-cve-2024-23897-revealed-1
Advisory 3
Other 6
- http://www.openwall.com/lists/oss-security/2024/01/24/6
- https://github.com/jenkinsci/jenkins/commit/554f03782057c499c49bbb06575f0d28b5200edb
- https://github.com/jenkinsci/jenkins
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-23897
- https://www.jenkins.io/changelog-stable/#v2.440.1
- https://www.sonarsource.com/blog/excessive-expansion-uncovering-critical-security-vulnerabilities-in-jenkins
More Jenkins vulnerabilities
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
- TI-2015-06740 The Jenkins CLI subsystem in Jenkins before 1.638 and LTS before 1.625.2 allows remote… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-23897 · CVE Program
- CVE-2024-23897 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-6f9g-cxwr-q5jr · GitHub Advisory Database · CC BY 4.0
- CVE-2024-23897 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences