Read the docs
TI-2011-04219 Aliases CVE-2011-4905GHSA-9wcx-326r-7j7w

Apache ActiveMQ before 5.6.0 allows remote attackers to cause a denial of service…

Priority LOW 34CWE-399Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Partial
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-399 and the CVSS impact.

Summary

Apache ActiveMQ before 5.6.0 allows remote attackers to cause a denial of service (file-descriptor exhaustion and broker crash or hang) by sending many openwire failover:tcp:// connection requests.

Why it matters now

EPSS 0.08507 95th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial org.apache.activemq:activemq-core (Maven): 5.6.0Red Hat: 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.apache.activemq:activemq-core (Maven)before 5.6.05.6.0Patch availableGHSA-9wcx-326r-7j7w
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.apache.activemq:activemq-core (Maven) Vendor— Affected before 5.6.0 Fixed in 5.6.0 Patch available GHSA-9wcx-326r-7j7w

CPE configurations NVD · 32

CPEVersionsRoleVendor
cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*up to 5.5.1VulnerableApache
cpe:2.3:a:apache:activemq:1.1:*:*:*:*:*:*:*1.1VulnerableApache
cpe:2.3:a:apache:activemq:1.2:*:*:*:*:*:*:*1.2VulnerableApache
cpe:2.3:a:apache:activemq:1.3:*:*:*:*:*:*:*1.3VulnerableApache
cpe:2.3:a:apache:activemq:1.4:*:*:*:*:*:*:*1.4VulnerableApache
cpe:2.3:a:apache:activemq:1.5:*:*:*:*:*:*:*1.5VulnerableApache
cpe:2.3:a:apache:activemq:2.0:*:*:*:*:*:*:*2.0VulnerableApache
cpe:2.3:a:apache:activemq:2.1:*:*:*:*:*:*:*2.1VulnerableApache
cpe:2.3:a:apache:activemq:3.0:*:*:*:*:*:*:*3.0VulnerableApache
cpe:2.3:a:apache:activemq:3.1:*:*:*:*:*:*:*3.1VulnerableApache
  • cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* Versions up to 5.5.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:1.1:*:*:*:*:*:*:* Versions 1.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:1.2:*:*:*:*:*:*:* Versions 1.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:1.3:*:*:*:*:*:*:* Versions 1.3 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:1.4:*:*:*:*:*:*:* Versions 1.4 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:1.5:*:*:*:*:*:*:* Versions 1.5 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:2.1:*:*:*:*:*:*:* Versions 2.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:3.1:*:*:*:*:*:*:* Versions 3.1 Vulnerable ·Apache
Show 22 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:apache:activemq:3.2:*:*:*:*:*:*:*3.2VulnerableApache
cpe:2.3:a:apache:activemq:3.2.1:*:*:*:*:*:*:*3.2.1VulnerableApache
cpe:2.3:a:apache:activemq:3.2.2:*:*:*:*:*:*:*3.2.2VulnerableApache
cpe:2.3:a:apache:activemq:4.0:*:*:*:*:*:*:*4.0VulnerableApache
cpe:2.3:a:apache:activemq:4.0:m4:*:*:*:*:*:*4.0 m4VulnerableApache
cpe:2.3:a:apache:activemq:4.0:rc2:*:*:*:*:*:*4.0 rc2VulnerableApache
cpe:2.3:a:apache:activemq:4.0.1:*:*:*:*:*:*:*4.0.1VulnerableApache
cpe:2.3:a:apache:activemq:4.0.2:*:*:*:*:*:*:*4.0.2VulnerableApache
cpe:2.3:a:apache:activemq:4.1.0:*:*:*:*:*:*:*4.1.0VulnerableApache
cpe:2.3:a:apache:activemq:4.1.1:*:*:*:*:*:*:*4.1.1VulnerableApache
cpe:2.3:a:apache:activemq:4.1.2:*:*:*:*:*:*:*4.1.2VulnerableApache
cpe:2.3:a:apache:activemq:5.0.0:*:*:*:*:*:*:*5.0.0VulnerableApache
cpe:2.3:a:apache:activemq:5.1.0:*:*:*:*:*:*:*5.1.0VulnerableApache
cpe:2.3:a:apache:activemq:5.2.0:*:*:*:*:*:*:*5.2.0VulnerableApache
cpe:2.3:a:apache:activemq:5.3.0:*:*:*:*:*:*:*5.3.0VulnerableApache
cpe:2.3:a:apache:activemq:5.3.1:*:*:*:*:*:*:*5.3.1VulnerableApache
cpe:2.3:a:apache:activemq:5.3.2:*:*:*:*:*:*:*5.3.2VulnerableApache
cpe:2.3:a:apache:activemq:5.4.0:*:*:*:*:*:*:*5.4.0VulnerableApache
cpe:2.3:a:apache:activemq:5.4.1:*:*:*:*:*:*:*5.4.1VulnerableApache
cpe:2.3:a:apache:activemq:5.4.2:*:*:*:*:*:*:*5.4.2VulnerableApache
cpe:2.3:a:apache:activemq:5.4.3:*:*:*:*:*:*:*5.4.3VulnerableApache
cpe:2.3:a:apache:activemq:5.5.0:*:*:*:*:*:*:*5.5.0VulnerableApache
  • cpe:2.3:a:apache:activemq:3.2:*:*:*:*:*:*:* Versions 3.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:3.2.2:*:*:*:*:*:*:* Versions 3.2.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.0:m4:*:*:*:*:*:* Versions 4.0 m4 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.0:rc2:*:*:*:*:*:* Versions 4.0 rc2 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.1.1:*:*:*:*:*:*:* Versions 4.1.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:4.1.2:*:*:*:*:*:*:* Versions 4.1.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.0.0:*:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.1.0:*:*:*:*:*:*:* Versions 5.1.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.2.0:*:*:*:*:*:*:* Versions 5.2.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.3.0:*:*:*:*:*:*:* Versions 5.3.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.3.1:*:*:*:*:*:*:* Versions 5.3.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.3.2:*:*:*:*:*:*:* Versions 5.3.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.4.0:*:*:*:*:*:*:* Versions 5.4.0 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.4.1:*:*:*:*:*:*:* Versions 5.4.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.4.2:*:*:*:*:*:*:* Versions 5.4.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.4.3:*:*:*:*:*:*:* Versions 5.4.3 Vulnerable ·Apache
  • cpe:2.3:a:apache:activemq:5.5.0:*:*:*:*:*:*:* Versions 5.5.0 Vulnerable ·Apache

Remediation

  • Fix · GHSA-9wcx-326r-7j7w org.apache.activemq:activemq-core (Maven) Fixed in 5.6.0 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat JBoss BRMS 5Affected—

Timeline

  1. 2026-10-02 Threatist record created from CVE-2011-4905
  2. 2026-10-03 Alias added: GHSA-9wcx-326r-7j7w
  3. 2026-10-24 EPSS moved to the 95th–99th percentile
  4. 2026-10-25 EPSS moved to the 90th–95th percentile
  5. 2026-10-28 EPSS moved to the 95th–99th percentile

References

  • TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
  • TI-2016-02587 The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote… KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-26494 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans KEVCVSS 3.1HIGH 8.8
  • TI-2013-05951 Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not… CVSS 3.1CRITICAL 9.8
  • TI-2021-04451 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.1
  • TI-2021-04446 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
See all 74 →

Sources