Cross-site scripting in zopefoundation zope2, zope3
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| zopefoundation | zope2, zope3 | 2.8 to before 2.8.12; 2.9 to before 2.9.12; 2.10 to before 2.10.11; 2.11 to before 2.11.6; and 2.12.x before 2.12.3; 3.1.1through 3.4.1 | 2.8.12, 2.9.12, 2.10.11, 2.11.6 | Patch available | CNA |
| — | zope (PyPI) | 3.1.1 to before 3.7.3 | 3.7.3 | Patch available | GHSA-vh6g-786f-hxxp |
| — | zope2 (PyPI) | before 2.12.22 | 2.12.22 | Patch available | GHSA-vh6g-786f-hxxp |
| — | zope2 (PyPI) | 2.13.0a1 to before 2.13.12 | 2.13.12 | Patch available | GHSA-vh6g-786f-hxxp |
- zope2, zope3 Vendorzopefoundation Affected 2.8 to before 2.8.12; 2.9 to before 2.9.12; 2.10 to before 2.10.11; 2.11 to before 2.11.6; and 2.12.x before 2.12.3; 3.1.1through 3.4.1 Fixed in 2.8.12, 2.9.12, 2.10.11, 2.11.6 Patch available CNA
- zope (PyPI) Vendor— Affected 3.1.1 to before 3.7.3 Fixed in 3.7.3 Patch available GHSA-vh6g-786f-hxxp
- zope2 (PyPI) Vendor— Affected before 2.12.22 Fixed in 2.12.22 Patch available GHSA-vh6g-786f-hxxp
- zope2 (PyPI) Vendor— Affected 2.13.0a1 to before 2.13.12 Fixed in 2.13.12 Patch available GHSA-vh6g-786f-hxxp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zope:zope:*:*:*:*:*:*:*:* | 2.8.0 to before 2.8.12; 2.9.0 to before 2.9.12; 2.10.0 to before 2.10.11; 2.11.0 to before 2.11.6; 2.12.0 to before 2.12.3; 3.1.1 – 3.4.1 | Vulnerable | zopefoundation |
- cpe:2.3:a:zope:zope:*:*:*:*:*:*:*:* Versions 2.8.0 to before 2.8.12; 2.9.0 to before 2.9.12; 2.10.0 to before 2.10.11; 2.11.0 to before 2.11.6; 2.12.0 to before 2.12.3; 3.1.1 – 3.4.1 Vulnerable ·zopefoundation
Remediation
- Fix · CNA zope2, zope3 (zope) Fixed in 2.8.12, 2.9.12, 2.10.11, 2.11.6
- Fix · GHSA-vh6g-786f-hxxp zope (PyPI) Fixed in 3.7.3 Advisory →
- Fix · GHSA-vh6g-786f-hxxp zope2 (PyPI) Fixed in 2.12.22 Advisory →
- Fix · GHSA-vh6g-786f-hxxp zope2 (PyPI) Fixed in 2.13.12 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Enterprise Linux 5
Timeline
- 2026-10-02 Threatist record created from CVE-2011-4924
- 2026-10-03 Alias added: GHSA-vh6g-786f-hxxp
References
Advisory 8
- https://security-tracker.debian.org/tracker/CVE-2011-4924
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2011-4924
- https://access.redhat.com/security/cve/cve-2011-4924
- http://www.openwall.com/lists/oss-security/2012/01/19/19
- http://www.openwall.com/lists/oss-security/2012/01/19/16
- http://www.openwall.com/lists/oss-security/2012/01/19/17
- http://www.openwall.com/lists/oss-security/2012/01/19/18
- https://nvd.nist.gov/vuln/detail/CVE-2011-4924
More zopefoundation Zope vulnerabilities
- TI-2011-03162 Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through… CVSS 2.0HIGH 9.3
- TI-2000-00062 The DTML implementation in the Z Object Publishing Environment (Zope) allows remote… CVSS 2.0HIGH 10.0
- TI-2021-12302 Remote Code Execution via traversal in TAL expressions CVSS 3.1HIGH 8.8
- TI-2021-12342 Remote Code Execution via traversal in TAL expressions CVSS 3.1HIGH 8.8
- TI-2005-03148 docutils in Zope 2.6, 2.7 before 2.7.8, and 2.8 before 2.8.2 allows remote attackers to… CVSS 2.0HIGH 7.5
- TI-2000-00483 The DocumentTemplate package in Zope 2.2 and earlier allows a remote attacker to modify… CVSS 2.0HIGH 7.5
Sources
- CVE-2011-4924 · CVE Program
- CVE-2011-4924 · NVD
- FIRST EPSS
- GHSA-vh6g-786f-hxxp · GitHub Advisory Database · CC BY 4.0
- CVE-2011-4924 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences