Cross-site scripting (XSS) vulnerability in jQuery before 1.6.3, when using location.hash…
Priority LOW 38CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in jQuery before 1.6.3, when using location.hash to select elements, allows remote attackers to inject arbitrary web script or HTML via a crafted tag.
Why it matters now
EPSS 0.19191 97th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial jquery (npm): 1.6.3jQuery (NuGet): 1.6.3+2 more productsRed Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | jquery (npm) | before 1.6.3 | 1.6.3 | Patch available | GHSA-579v-mp3v-rrw5 |
| — | jQuery (NuGet) | before 1.6.3 | 1.6.3 | Patch available | GHSA-579v-mp3v-rrw5 |
| — | jquery-rails (RubyGems) | before 1.0.16 | 1.0.16 | Patch available | GHSA-579v-mp3v-rrw5 |
| — | org.webjars.npm:jquery (Maven) | before 1.6.3 | 1.6.3 | Patch available | GHSA-579v-mp3v-rrw5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- jquery (npm) Vendor— Affected before 1.6.3 Fixed in 1.6.3 Patch available GHSA-579v-mp3v-rrw5
- jQuery (NuGet) Vendor— Affected before 1.6.3 Fixed in 1.6.3 Patch available GHSA-579v-mp3v-rrw5
- jquery-rails (RubyGems) Vendor— Affected before 1.0.16 Fixed in 1.0.16 Patch available GHSA-579v-mp3v-rrw5
- org.webjars.npm:jquery (Maven) Vendor— Affected before 1.6.3 Fixed in 1.6.3 Patch available GHSA-579v-mp3v-rrw5
Remediation
- Fix · GHSA-579v-mp3v-rrw5 jquery (npm) Fixed in 1.6.3 Advisory →
- Fix · GHSA-579v-mp3v-rrw5 jQuery (NuGet) Fixed in 1.6.3 Advisory →
- Fix · GHSA-579v-mp3v-rrw5 jquery-rails (RubyGems) Fixed in 1.0.16 Advisory →
- Fix · GHSA-579v-mp3v-rrw5 org.webjars.npm:jquery (Maven) Fixed in 1.6.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Process Automation 7 | Affected | No fix planned: Out of support scope |
Timeline
- 2026-10-02 Threatist record created from CVE-2011-4969
- 2026-10-03 Alias added: GHSA-579v-mp3v-rrw5
References
Other 15
- 80056
- http://bugs.jquery.com/ticket/9521
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05111017
- http://blog.jquery.com/2011/09/01/jquery-1-6-3-released/
- http://blog.mindedsecurity.com/2011/07/jquery-is-sink.html
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05158380
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05232730
- [oss-security] 20130130 jQuery 1.6.2 XSS CVE assignment
- https://security.netapp.com/advisory/ntap-20190416-0007/
- [pulsar-commits] 20190416 [GitHub] [pulsar] one70six opened a new issue #4057: Security Vulnerabilities - Black Duck Scan - Pulsar v.2.3.1
- https://github.com/jquery/jquery
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/jquery-rails/CVE-2011-4969.yml
- https://lists.apache.org/thread.html/ff8dcfe29377088ab655fda9d585dccd5b1f07fabd94ae84fd60a7f8@%3Ccommits.pulsar.apache.org%3E
- https://security.netapp.com/advisory/ntap-20190416-0007
- http://blog.jquery.com/2011/09/01/jquery-1-6-3-released
More Jquery vulnerabilities
- TI-2020-08897 Potential XSS vulnerability in jQuery KEVCVSS 3.1MEDIUM 6.9
- TI-2020-08896 jQuery has a potential XSS vulnerability CVSS 3.1MEDIUM 6.9
- TI-2019-08480 jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles… CVSS 3.1MEDIUM 6.1
- TI-2015-07630 jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a… CVSS 3.0MEDIUM 6.1
- TI-2016-08748 jQuery 3.0.0-rc.1 is vulnerable to Denial of Service (DoS) due to removing a logic that… CVSS 3.1HIGH 7.5
- TI-2012-05410 jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2011-4969 · CVE Program
- CVE-2011-4969 · NVD
- FIRST EPSS
- GHSA-579v-mp3v-rrw5 · GitHub Advisory Database · CC BY 4.0
- CVE-2011-4969 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences