jQuery 3.0.0-rc.1 is vulnerable to Denial of Service (DoS) due to removing a logic that…
Priority LOW 39CWE-674Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-674.
Summary
jQuery 3.0.0-rc.1 is vulnerable to Denial of Service (DoS) due to removing a logic that lowercased attribute names. Any attribute getter using a mixed-cased name for boolean attributes goes into an infinite recursion, exceeding the stack call limit.
Why it matters now
EPSS 0.03232 88th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed jquery (npm): 3.0.0jQuery (NuGet): 3.0.0+2 more products
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | jquery (npm) | 3.0.0-rc.1 to before 3.0.0 | 3.0.0 | Patch available | GHSA-mhpp-875w-9cpv |
| — | jQuery (NuGet) | 3.0.0-rc.1 to before 3.0.0 | 3.0.0 | Patch available | GHSA-mhpp-875w-9cpv |
| — | org.webjars.npm:jquery (Maven) | 3.0.0-rc1 to before 3.0.0 | 3.0.0 | Patch available | GHSA-mhpp-875w-9cpv |
| — | jquery-rails (RubyGems) | 3.0.0-rc.1 to before 3.0.0 | 3.0.0 | Patch available | GHSA-mhpp-875w-9cpv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- jquery (npm) Vendor— Affected 3.0.0-rc.1 to before 3.0.0 Fixed in 3.0.0 Patch available GHSA-mhpp-875w-9cpv
- jQuery (NuGet) Vendor— Affected 3.0.0-rc.1 to before 3.0.0 Fixed in 3.0.0 Patch available GHSA-mhpp-875w-9cpv
- org.webjars.npm:jquery (Maven) Vendor— Affected 3.0.0-rc1 to before 3.0.0 Fixed in 3.0.0 Patch available GHSA-mhpp-875w-9cpv
- jquery-rails (RubyGems) Vendor— Affected 3.0.0-rc.1 to before 3.0.0 Fixed in 3.0.0 Patch available GHSA-mhpp-875w-9cpv
Remediation
- Fix · GHSA-mhpp-875w-9cpv jquery (npm) Fixed in 3.0.0 Advisory →
- Fix · GHSA-mhpp-875w-9cpv jQuery (NuGet) Fixed in 3.0.0 Advisory →
- Fix · GHSA-mhpp-875w-9cpv org.webjars.npm:jquery (Maven) Fixed in 3.0.0 Advisory →
- Fix · GHSA-mhpp-875w-9cpv jquery-rails (RubyGems) Fixed in 3.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10707
- 2026-10-03 Alias added: GHSA-mhpp-875w-9cpv
References
Advisory 2
More Jquery vulnerabilities
- TI-2020-08897 Potential XSS vulnerability in jQuery KEVCVSS 3.1MEDIUM 6.9
- TI-2020-08896 jQuery has a potential XSS vulnerability CVSS 3.1MEDIUM 6.9
- TI-2019-08480 jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles… CVSS 3.1MEDIUM 6.1
- TI-2015-07630 jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a… CVSS 3.0MEDIUM 6.1
- TI-2012-05410 jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. CVSS 3.0MEDIUM 6.1
- TI-2011-04277 Cross-site scripting (XSS) vulnerability in jQuery before 1.6.3, when using location.hash… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2016-10707 · CVE Program
- CVE-2016-10707 · NVD
- FIRST EPSS
- GHSA-mhpp-875w-9cpv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences