Interaction error in the PostgreSQL JDBC driver before 8.2, when used with a PostgreSQL…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
Interaction error in the PostgreSQL JDBC driver before 8.2, when used with a PostgreSQL server with the "standard_conforming_strings" option enabled, such as the default configuration of PostgreSQL 9.1, does not properly escape unspecified JDBC statement parameters, which allows remote attackers to perform SQL injection attacks. NOTE: as of 20120330, it was claimed that the upstream developer planned to dispute this issue, but an official dispute has not been posted as of 20121005.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.postgresql:postgresql (Maven) | before 8.2 | 8.2 | Patch available | GHSA-h86w-m5rm-xr33 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.postgresql:postgresql (Maven) Vendor— Affected before 8.2 Fixed in 8.2 Patch available GHSA-h86w-m5rm-xr33
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:postgresql:postgresql:9.1:*:*:*:*:*:*:* | 9.1 | Vulnerable | PostgreSQL |
| cpe:2.3:a:postgresql:postgresql_jdbc_driver:8.1:*:*:*:*:*:*:* | 8.1 | Vulnerable | PostgreSQL |
- cpe:2.3:a:postgresql:postgresql:9.1:*:*:*:*:*:*:* Versions 9.1 Vulnerable ·PostgreSQL
- cpe:2.3:a:postgresql:postgresql_jdbc_driver:8.1:*:*:*:*:*:*:* Versions 8.1 Vulnerable ·PostgreSQL
Remediation
- Fix · GHSA-h86w-m5rm-xr33 org.postgresql:postgresql (Maven) Fixed in 8.2 Advisory →
Vendor assessments
Red Hat
Not affected: 2 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
Timeline
- 2026-10-02 Threatist record created from CVE-2012-1618
- 2026-10-03 Alias added: GHSA-h86w-m5rm-xr33
References
Other 13
- [oss-security] 20120330 postgresql-jdbc 8.1 SQL injection with postgresql server 9.1
- [oss-security] 20120402 Re: [JDBC] CVE DISPUTE notification: postgresql-jdbc: SQL injection due improper escaping of JDBC statement parameters
- https://bugzilla.novell.com/show_bug.cgi?id=754273
- [oss-security] 20120404 Re: CVE DISPUTE notification: postgresql-jdbc: SQL injection due improper escaping of JDBC statement parameters
- 80641
- [opensuse-security] 20120325 SQL injection attack possible when connecting to PostgreSQL 9.1 with version 8.1 JDBC driver
- [oss-security] 20120404 Re: Re: [JDBC] CVE DISPUTE notification: postgresql-jdbc: SQL injection due improper escaping of JDBC statement parameters
- [oss-security] 20120404 Re: Re: [pgsql-security] postgresql-jdbc 8.1 SQL injection with postgresql server 9.1
- [oss-security] 20120330 CVE DISPUTE notification: postgresql-jdbc: SQL injection due improper escaping of JDBC statement parameters
- [oss-security] 20120404 Re: CVE DISPUTE notification: postgresql-jdbc: SQL injection due improper escaping of JDBC statement parameters
- [oss-security] 20120331 SQL injection attack possible when connecting to PostgreSQL 9.1 with version 8.1 JDBC driver
- 20120325 SQL injection attack possible when connecting to PostgreSQL 9.1 with version 8.1 JDBC driver
- https://github.com/pgjdbc/pgjdbc
More Postgresql vulnerabilities
- TI-2019-06651 In PostgreSQL 9.3 through 11.2, the "COPY TO/FROM PROGRAM" function allows superusers and… CVSS 3.0HIGH 7.2
- TI-2017-05187 Improper authentication in postgresql CVSS 3.0CRITICAL 9.8
- TI-2020-15711 SQL injection in postgresql CVSS 3.1HIGH 8.8
- TI-2013-01675 Argument injection vulnerability in PostgreSQL 9.2.x before 9.2.4, 9.1.x before 9.1.9… CVSS 2.0MEDIUM 6.5
- TI-2007-03176 The Database Link library (dblink) in PostgreSQL 8.1 implements functions via CREATE… CVSS 2.0HIGH 9.0
- TI-2022-01423 SQL injection in postgresql CVSS 3.1HIGH 8.8
Sources
- CVE-2012-1618 · CVE Program
- CVE-2012-1618 · NVD
- FIRST EPSS
- GHSA-h86w-m5rm-xr33 · GitHub Advisory Database · CC BY 4.0
- CVE-2012-1618 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences