Cross-site scripting in Quicktabs
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-site scripting vulnerability (XSS) in the Quick Tabs module 6.x-2.x before 6.x-2.1, 6.x-3.x before 6.x-3.1, and 7.x-3.x before 7.x-3.3 for Drupal.
Why it matters now
EPSS 0.00528 44th percentileScored 2026-11-07
Fix Fixed Quicktabs (Quick Tabs): 6.x-2.1, 6.x-3.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Quick Tabs | Quicktabs | 6.x-2 to before 6.x-2.1; 6.x-3 to before 6.x-3.1; and 7.x-3.x before 7.x-3.3 | 6.x-2.1, 6.x-3.1 | Patch available | CNA |
- Quicktabs VendorQuick Tabs Affected 6.x-2 to before 6.x-2.1; 6.x-3 to before 6.x-3.1; and 7.x-3.x before 7.x-3.3 Fixed in 6.x-2.1, 6.x-3.1 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:quick_tabs_project:quick_tabs:6.x-2.0:*:*:*:*:drupal:*:* | 6.x-2.0 | Vulnerable | Quick Tabs Project |
| cpe:2.3:a:quick_tabs_project:quick_tabs:6.x-3.0:*:*:*:*:drupal:*:* | 6.x-3.0 | Vulnerable | Quick Tabs Project |
| cpe:2.3:a:quick_tabs_project:quick_tabs:7.x-3.0:*:*:*:*:drupal:*:* | 7.x-3.0 | Vulnerable | Quick Tabs Project |
| cpe:2.3:a:quick_tabs_project:quick_tabs:7.x-3.1:*:*:*:*:drupal:*:* | 7.x-3.1 | Vulnerable | Quick Tabs Project |
| cpe:2.3:a:quick_tabs_project:quick_tabs:7.x-3.2:*:*:*:*:drupal:*:* | 7.x-3.2 | Vulnerable | Quick Tabs Project |
- cpe:2.3:a:quick_tabs_project:quick_tabs:6.x-2.0:*:*:*:*:drupal:*:* Versions 6.x-2.0 Vulnerable ·Quick Tabs Project
- cpe:2.3:a:quick_tabs_project:quick_tabs:6.x-3.0:*:*:*:*:drupal:*:* Versions 6.x-3.0 Vulnerable ·Quick Tabs Project
- cpe:2.3:a:quick_tabs_project:quick_tabs:7.x-3.0:*:*:*:*:drupal:*:* Versions 7.x-3.0 Vulnerable ·Quick Tabs Project
- cpe:2.3:a:quick_tabs_project:quick_tabs:7.x-3.1:*:*:*:*:drupal:*:* Versions 7.x-3.1 Vulnerable ·Quick Tabs Project
- cpe:2.3:a:quick_tabs_project:quick_tabs:7.x-3.2:*:*:*:*:drupal:*:* Versions 7.x-3.2 Vulnerable ·Quick Tabs Project
Remediation
- Fix · CNA Quicktabs (Quick Tabs) Fixed in 6.x-2.1, 6.x-3.1
Timeline
- 2026-10-02 Threatist record created from CVE-2012-1637
- 2026-10-03 Alias added: GHSA-7cgr-vc35-72hr
References
More Quick Tabs Project Quick Tabs vulnerabilities
- TI-2026-51589 Quick Tabs - Moderately critical - Access bypass - SA-CONTRIB-2026-099 CVSS 3.1MEDIUM 5.3
Sources
- CVE-2012-1637 · CVE Program
- CVE-2012-1637 · NVD
- FIRST EPSS
- GHSA-7cgr-vc35-72hr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences