Multiple directory traversal vulnerabilities in the cssgen contrib module in GeSHi before…
Priority LOW 29CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Multiple directory traversal vulnerabilities in the cssgen contrib module in GeSHi before 1.0.8.11 allow remote attackers to read arbitrary files via a .. (dot dot) in the (1) geshi-path or (2) geshi-lang-path parameter.
Why it matters now
EPSS 0.03174 88th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed geshi/geshi (Packagist): 1.0.8.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | geshi/geshi (Packagist) | before 1.0.8.11 | 1.0.8.11 | Patch available | GHSA-fw3x-2pr2-5j64 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- geshi/geshi (Packagist) Vendor— Affected before 1.0.8.11 Fixed in 1.0.8.11 Patch available GHSA-fw3x-2pr2-5j64
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qbnz:geshi:*:*:*:*:*:*:*:* | up to 1.0.8.10 | Vulnerable | Qbnz |
| cpe:2.3:a:qbnz:geshi:1.0.8.4:*:*:*:*:*:*:* | 1.0.8.4 | Vulnerable | Qbnz |
| cpe:2.3:a:qbnz:geshi:1.0.8.5:*:*:*:*:*:*:* | 1.0.8.5 | Vulnerable | Qbnz |
| cpe:2.3:a:qbnz:geshi:1.0.8.6:*:*:*:*:*:*:* | 1.0.8.6 | Vulnerable | Qbnz |
| cpe:2.3:a:qbnz:geshi:1.0.8.7:*:*:*:*:*:*:* | 1.0.8.7 | Vulnerable | Qbnz |
| cpe:2.3:a:qbnz:geshi:1.0.8.8:*:*:*:*:*:*:* | 1.0.8.8 | Vulnerable | Qbnz |
| cpe:2.3:a:qbnz:geshi:1.0.8.9:*:*:*:*:*:*:* | 1.0.8.9 | Vulnerable | Qbnz |
- cpe:2.3:a:qbnz:geshi:*:*:*:*:*:*:*:* Versions up to 1.0.8.10 Vulnerable ·Qbnz
- cpe:2.3:a:qbnz:geshi:1.0.8.4:*:*:*:*:*:*:* Versions 1.0.8.4 Vulnerable ·Qbnz
- cpe:2.3:a:qbnz:geshi:1.0.8.5:*:*:*:*:*:*:* Versions 1.0.8.5 Vulnerable ·Qbnz
- cpe:2.3:a:qbnz:geshi:1.0.8.6:*:*:*:*:*:*:* Versions 1.0.8.6 Vulnerable ·Qbnz
- cpe:2.3:a:qbnz:geshi:1.0.8.7:*:*:*:*:*:*:* Versions 1.0.8.7 Vulnerable ·Qbnz
- cpe:2.3:a:qbnz:geshi:1.0.8.8:*:*:*:*:*:*:* Versions 1.0.8.8 Vulnerable ·Qbnz
- cpe:2.3:a:qbnz:geshi:1.0.8.9:*:*:*:*:*:*:* Versions 1.0.8.9 Vulnerable ·Qbnz
Remediation
- Fix · GHSA-fw3x-2pr2-5j64 geshi/geshi (Packagist) Fixed in 1.0.8.11 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2012-3521
- 2026-10-03 Alias added: GHSA-fw3x-2pr2-5j64
References
Advisory 4
Other 4
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=685324
- [oss-security] 20120821 Re: CVE Request -- php-geshi / GeSHi (1.0.8.11): Remote directory traversal and information disclosure in the cssgen contrib module (plus possibly XSS, but it needs upstream to confirm)
- https://github.com/GeSHi/geshi-1.0
- http://sourceforge.net/p/geshi/code/2507
More Qbnz Geshi vulnerabilities
- TI-2025-01860 GeSHi CSS cssgen.php get_var cross site scripting CVSS 4.0MEDIUM 5.1
- TI-2012-03050 Cross-site scripting (XSS) vulnerability in contrib/langwiz.php in GeSHi before 1.0.8.11… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2012-3521 · CVE Program
- CVE-2012-3521 · NVD
- FIRST EPSS
- GHSA-fw3x-2pr2-5j64 · GitHub Advisory Database · CC BY 4.0
- CVE-2012-3521 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences