Cross-site scripting (XSS) vulnerability in contrib/langwiz.php in GeSHi before 1.0.8.11…
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in contrib/langwiz.php in GeSHi before 1.0.8.11 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Why it matters now
EPSS 0.0124 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed geshi/geshi (Packagist): 1.0.8.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | geshi/geshi (Packagist) | before 1.0.8.11 | 1.0.8.11 | Patch available | GHSA-f3f3-5q5j-6v47 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- geshi/geshi (Packagist) Vendor— Affected before 1.0.8.11 Fixed in 1.0.8.11 Patch available GHSA-f3f3-5q5j-6v47
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qbnz:geshi:*:*:*:*:*:*:*:* | up to 1.0.8.10 | Vulnerable | Qbnz |
| cpe:2.3:a:qbnz:geshi:1.0.8.4:*:*:*:*:*:*:* | 1.0.8.4 | Vulnerable | Qbnz |
| cpe:2.3:a:qbnz:geshi:1.0.8.5:*:*:*:*:*:*:* | 1.0.8.5 | Vulnerable | Qbnz |
| cpe:2.3:a:qbnz:geshi:1.0.8.6:*:*:*:*:*:*:* | 1.0.8.6 | Vulnerable | Qbnz |
| cpe:2.3:a:qbnz:geshi:1.0.8.7:*:*:*:*:*:*:* | 1.0.8.7 | Vulnerable | Qbnz |
| cpe:2.3:a:qbnz:geshi:1.0.8.8:*:*:*:*:*:*:* | 1.0.8.8 | Vulnerable | Qbnz |
| cpe:2.3:a:qbnz:geshi:1.0.8.9:*:*:*:*:*:*:* | 1.0.8.9 | Vulnerable | Qbnz |
- cpe:2.3:a:qbnz:geshi:*:*:*:*:*:*:*:* Versions up to 1.0.8.10 Vulnerable ·Qbnz
- cpe:2.3:a:qbnz:geshi:1.0.8.4:*:*:*:*:*:*:* Versions 1.0.8.4 Vulnerable ·Qbnz
- cpe:2.3:a:qbnz:geshi:1.0.8.5:*:*:*:*:*:*:* Versions 1.0.8.5 Vulnerable ·Qbnz
- cpe:2.3:a:qbnz:geshi:1.0.8.6:*:*:*:*:*:*:* Versions 1.0.8.6 Vulnerable ·Qbnz
- cpe:2.3:a:qbnz:geshi:1.0.8.7:*:*:*:*:*:*:* Versions 1.0.8.7 Vulnerable ·Qbnz
- cpe:2.3:a:qbnz:geshi:1.0.8.8:*:*:*:*:*:*:* Versions 1.0.8.8 Vulnerable ·Qbnz
- cpe:2.3:a:qbnz:geshi:1.0.8.9:*:*:*:*:*:*:* Versions 1.0.8.9 Vulnerable ·Qbnz
Remediation
- Fix · GHSA-f3f3-5q5j-6v47 geshi/geshi (Packagist) Fixed in 1.0.8.11 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2012-3522
- 2026-10-03 Alias added: GHSA-f3f3-5q5j-6v47
References
Advisory 4
Other 6
- [oss-security] 20120821 Re: CVE Request -- php-geshi / GeSHi (1.0.8.11): Remote directory traversal and information disclosure in the cssgen contrib module (plus possibly XSS, but it needs upstream to confirm)
- https://github.com/GeSHi/geshi-1.0
- https://lists.fedorahosted.org/archives/list/[email protected]/message/AE33KOZ42XXG6DSH5SNGOTC3NS7FWZ2I
- https://lists.fedorahosted.org/archives/list/[email protected]/message/H2R65LEAIDK6I53IYGZWDCRETBYKNUKF
- https://lists.fedorahosted.org/archives/list/[email protected]/message/JA5TA3T7AJXWM4QMI62LMGW62WZUULGB
- http://sourceforge.net/p/geshi/code/2508
More Qbnz Geshi vulnerabilities
- TI-2025-01860 GeSHi CSS cssgen.php get_var cross site scripting CVSS 4.0MEDIUM 5.1
- TI-2012-03049 Multiple directory traversal vulnerabilities in the cssgen contrib module in GeSHi before… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2012-3522 · CVE Program
- CVE-2012-3522 · NVD
- FIRST EPSS
- GHSA-f3f3-5q5j-6v47 · GitHub Advisory Database · CC BY 4.0
- CVE-2012-3522 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences