Improper input validation in jenkins
Priority MEDIUM 43CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers with read access and HTTP access to Jenkins master to insert data and execute arbitrary code.
Why it matters now
EPSS 0.02385 84th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 1.466.2, 1.482Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | jenkins | 1.447.2 | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 1.466.2 | 1.466.2 | Patch available | GHSA-wr6p-j63r-xqhv |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 1.467 to before 1.482 | 1.482 | Patch available | GHSA-wr6p-j63r-xqhv |
- jenkins VendorJenkins Affected 1.447.2 Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 1.466.2 Fixed in 1.466.2 Patch available GHSA-wr6p-j63r-xqhv
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.467 to before 1.482 Fixed in 1.482 Patch available GHSA-wr6p-j63r-xqhv
Remediation
- Fix · GHSA-wr6p-j63r-xqhv org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.466.2 Advisory →
- Fix · GHSA-wr6p-j63r-xqhv org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.482 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Enterprise 1 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2012-4438
- 2026-10-03 Alias added: GHSA-wr6p-j63r-xqhv
References
Advisory 5
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2012-4438 · CVE Program
- CVE-2012-4438 · NVD
- FIRST EPSS
- GHSA-wr6p-j63r-xqhv · GitHub Advisory Database · CC BY 4.0
- CVE-2012-4438 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences