Cross-site scripting in jenkins
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site Scripting (XSS) in Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers to inject arbitrary web script or HTML in the Violations plugin.
Why it matters now
EPSS 0.01867 79th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:violations (Maven): 0.7.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | jenkins | 2 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:violations (Maven) | before 0.7.11 | 0.7.11 | Patch available | GHSA-5qpv-27q3-6484 |
- jenkins VendorJenkins Affected 2 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:violations (Maven) Vendor— Affected before 0.7.11 Fixed in 0.7.11 Patch available GHSA-5qpv-27q3-6484
Remediation
- Fix · GHSA-5qpv-27q3-6484 org.jenkins-ci.plugins:violations (Maven) Fixed in 0.7.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2012-4440
- 2026-10-03 Alias added: GHSA-5qpv-27q3-6484
References
Advisory 4
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2012-4440 · CVE Program
- CVE-2012-4440 · NVD
- FIRST EPSS
- GHSA-5qpv-27q3-6484 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences