Read the docs
TI-2012-03783 Aliases CVE-2012-4441GHSA-3qxr-q72q-hmwp

Cross-site scripting in jenkins

Priority LOW 31CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Cross-site Scripting (XSS) in Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers to inject arbitrary web script or HTML in the CI game plugin.

Why it matters now

EPSS 0.01867 79th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:ci-game (Maven): 1.19

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Jenkinsjenkins1.482—No fix listedCNA
—org.jenkins-ci.plugins:ci-game (Maven)before 1.191.19Patch availableGHSA-3qxr-q72q-hmwp
  • jenkins VendorJenkins Affected 1.482 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:ci-game (Maven) Vendor— Affected before 1.19 Fixed in 1.19 Patch available GHSA-3qxr-q72q-hmwp

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*before 1.466.2VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*before 1.482VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions before 1.466.2 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions before 1.482 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-3qxr-q72q-hmwp org.jenkins-ci.plugins:ci-game (Maven) Fixed in 1.19 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2012-4441
  2. 2026-10-03 Alias added: GHSA-3qxr-q72q-hmwp

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources