Read the docs
TI-2012-05076 Aliases CVE-2012-6112GHSA-fx5h-3786-h2w6

classes/GoogleSpell.php in the PHP Spellchecker (aka Google Spellchecker) addon before…

Priority LOW 27CWE-264Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.

Summary

classes/GoogleSpell.php in the PHP Spellchecker (aka Google Spellchecker) addon before 2.0.6.1 for TinyMCE, as used in Moodle 2.1.x before 2.1.10, 2.2.x before 2.2.7, 2.3.x before 2.3.4, and 2.4.x before 2.4.1 and other products, does not properly handle control characters, which allows remote attackers to trigger arbitrary outbound HTTP requests via a crafted string.

Why it matters now

EPSS 0.02288 83rd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.1.10, 2.2.7, 2.3.4 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)2.1.0 to before 2.1.102.1.10Patch availableGHSA-fx5h-3786-h2w6
—moodle/moodle (Packagist)2.2.0 to before 2.2.72.2.7Patch availableGHSA-fx5h-3786-h2w6
—moodle/moodle (Packagist)2.3.0 to before 2.3.42.3.4Patch availableGHSA-fx5h-3786-h2w6
—moodle/moodle (Packagist)2.4.0 to before 2.4.12.4.1Patch availableGHSA-fx5h-3786-h2w6
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 2.1.0 to before 2.1.10 Fixed in 2.1.10 Patch available GHSA-fx5h-3786-h2w6
  • moodle/moodle (Packagist) Vendor— Affected 2.2.0 to before 2.2.7 Fixed in 2.2.7 Patch available GHSA-fx5h-3786-h2w6
  • moodle/moodle (Packagist) Vendor— Affected 2.3.0 to before 2.3.4 Fixed in 2.3.4 Patch available GHSA-fx5h-3786-h2w6
  • moodle/moodle (Packagist) Vendor— Affected 2.4.0 to before 2.4.1 Fixed in 2.4.1 Patch available GHSA-fx5h-3786-h2w6

CPE configurations NVD · 33

CPEVersionsRoleVendor
cpe:2.3:a:tinymce:spellchecker_php:2.0:*:*:*:*:*:*:*2.0Vulnerabletinymce
cpe:2.3:a:tinymce:spellchecker_php:2.0:a1:*:*:*:*:*:*2.0 a1Vulnerabletinymce
cpe:2.3:a:tinymce:spellchecker_php:2.0:a2:*:*:*:*:*:*2.0 a2Vulnerabletinymce
cpe:2.3:a:tinymce:spellchecker_php:2.0:b1:*:*:*:*:*:*2.0 b1Vulnerabletinymce
cpe:2.3:a:tinymce:spellchecker_php:2.0:b2:*:*:*:*:*:*2.0 b2Vulnerabletinymce
cpe:2.3:a:tinymce:spellchecker_php:2.0:b3:*:*:*:*:*:*2.0 b3Vulnerabletinymce
cpe:2.3:a:tinymce:spellchecker_php:2.0:rc1:*:*:*:*:*:*2.0 rc1Vulnerabletinymce
cpe:2.3:a:tinymce:spellchecker_php:2.0.1:*:*:*:*:*:*:*2.0.1Vulnerabletinymce
cpe:2.3:a:tinymce:spellchecker_php:2.0.2:*:*:*:*:*:*:*2.0.2Vulnerabletinymce
cpe:2.3:a:tinymce:spellchecker_php:2.0.3:*:*:*:*:*:*:*2.0.3Vulnerabletinymce
  • cpe:2.3:a:tinymce:spellchecker_php:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·tinymce
  • cpe:2.3:a:tinymce:spellchecker_php:2.0:a1:*:*:*:*:*:* Versions 2.0 a1 Vulnerable ·tinymce
  • cpe:2.3:a:tinymce:spellchecker_php:2.0:a2:*:*:*:*:*:* Versions 2.0 a2 Vulnerable ·tinymce
  • cpe:2.3:a:tinymce:spellchecker_php:2.0:b1:*:*:*:*:*:* Versions 2.0 b1 Vulnerable ·tinymce
  • cpe:2.3:a:tinymce:spellchecker_php:2.0:b2:*:*:*:*:*:* Versions 2.0 b2 Vulnerable ·tinymce
  • cpe:2.3:a:tinymce:spellchecker_php:2.0:b3:*:*:*:*:*:* Versions 2.0 b3 Vulnerable ·tinymce
  • cpe:2.3:a:tinymce:spellchecker_php:2.0:rc1:*:*:*:*:*:* Versions 2.0 rc1 Vulnerable ·tinymce
  • cpe:2.3:a:tinymce:spellchecker_php:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·tinymce
  • cpe:2.3:a:tinymce:spellchecker_php:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·tinymce
  • cpe:2.3:a:tinymce:spellchecker_php:2.0.3:*:*:*:*:*:*:* Versions 2.0.3 Vulnerable ·tinymce
Show 23 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:tinymce:spellchecker_php:2.0.6:*:*:*:*:*:*:*2.0.6Vulnerabletinymce
cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:*2.1.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:*2.1.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:*2.1.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.3:*:*:*:*:*:*:*2.1.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.4:*:*:*:*:*:*:*2.1.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.5:*:*:*:*:*:*:*2.1.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.6:*:*:*:*:*:*:*2.1.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.7:*:*:*:*:*:*:*2.1.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.8:*:*:*:*:*:*:*2.1.8VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.9:*:*:*:*:*:*:*2.1.9VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:*2.2.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.1:*:*:*:*:*:*:*2.2.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.2:*:*:*:*:*:*:*2.2.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.3:*:*:*:*:*:*:*2.2.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.4:*:*:*:*:*:*:*2.2.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.5:*:*:*:*:*:*:*2.2.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.6:*:*:*:*:*:*:*2.2.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.3.0:*:*:*:*:*:*:*2.3.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.3.1:*:*:*:*:*:*:*2.3.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.3.2:*:*:*:*:*:*:*2.3.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.3.3:*:*:*:*:*:*:*2.3.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.4.0:*:*:*:*:*:*:*2.4.0VulnerableMoodle
  • cpe:2.3:a:tinymce:spellchecker_php:2.0.6:*:*:*:*:*:*:* Versions 2.0.6 Vulnerable ·tinymce
  • cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.3:*:*:*:*:*:*:* Versions 2.1.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.4:*:*:*:*:*:*:* Versions 2.1.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.5:*:*:*:*:*:*:* Versions 2.1.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.6:*:*:*:*:*:*:* Versions 2.1.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.7:*:*:*:*:*:*:* Versions 2.1.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.8:*:*:*:*:*:*:* Versions 2.1.8 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.9:*:*:*:*:*:*:* Versions 2.1.9 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.2:*:*:*:*:*:*:* Versions 2.2.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.3:*:*:*:*:*:*:* Versions 2.2.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.4:*:*:*:*:*:*:* Versions 2.2.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.5:*:*:*:*:*:*:* Versions 2.2.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.6:*:*:*:*:*:*:* Versions 2.2.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.3.1:*:*:*:*:*:*:* Versions 2.3.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.3.2:*:*:*:*:*:*:* Versions 2.3.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.3.3:*:*:*:*:*:*:* Versions 2.3.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-fx5h-3786-h2w6 moodle/moodle (Packagist) Fixed in 2.1.10 Advisory →
  • Fix · GHSA-fx5h-3786-h2w6 moodle/moodle (Packagist) Fixed in 2.2.7 Advisory →
  • Fix · GHSA-fx5h-3786-h2w6 moodle/moodle (Packagist) Fixed in 2.3.4 Advisory →
  • Fix · GHSA-fx5h-3786-h2w6 moodle/moodle (Packagist) Fixed in 2.4.1 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2012-6112
  2. 2026-10-03 Alias added: GHSA-fx5h-3786-h2w6

References

Sources